最大流模板 HDU1532

关于最大流EK算法

http://blog.csdn.net/hurmishine/article/details/53037362点击打开链接

HDU1532

Drainage Ditches
Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50
模板代码注释详解

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int S=200+5;
const int MAX=1e8;
int N,M;      //N 路径数 M 结点数
int map[S][S];
int pre[S];  //记录结点i的前驱
int vis[S];  //标记结点是否已访问
//用BFS判断从结点s到t路径上是否还有delta
//即s,t之间是否还有增广路径,若有,返回1,否则返回0
int BFS(int s,int t)
{
    queue<int>que;
    memset(pre,-1,sizeof(pre)); //pre数组初始化为-1,即没有前驱
    memset(vis,0,sizeof(vis));  //vis数组初始化为0,未访问
    pre[s]=s;
    vis[s]=1;
    que.push(s);  //记录前驱,标记已访问,入队
    int p;
    while(!que.empty())
    {
        p=que.front();
        que.pop();
        for(int i=1;i<=M;i++)   //遍历
        {
            if(map[p][i]>0&&!vis[i])   //存在未访问的路径
            {
                pre[i]=p;
                vis[i]=1;
                if(i==t)
                    return 1;  //存在s到t的增广路径
                que.push(i);
            }
        }
    }
    return 0;   //队列为空,不存在s到t的增广路径
}
//EK求最大流
int EK(int s,int t)
{
    int maxa=0,d;
    while(BFS(s,t)) //存在s到t的增广路径
    {
        d=MAX;
        for(int i=t;i!=s;i=pre[i])   //倒着找出最小容量
        {
            d=min(d,map[pre[i]][i]);
        }
        for(int i=t;i!=s;i=pre[i])
        {
            map[pre[i]][i]-=d;
            map[i][pre[i]]+=d;     //加上反向边
        }
        maxa+=d;
    }
    return maxa;
}
int main()
{
    while(~scanf("%d%d",&N,&M))
    {
        memset(map,0,sizeof(map));  //map数组初始化为0
        for(int i=1;i<=N;i++)
        {
            int a,b,v;
            scanf("%d%d%d",&a,&b,&v);
            map[a][b]+=v;     //*** map初始化为0,为防止有重边,map[a][b]+=v而不是map[a][b]=v
        }
        printf("%d\n",EK(1,M));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值