2019_GDUT_新生专题I选集 A-尺取 POJ-3061

题目:

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

分析:尺取法,两个变量模拟尺头和尺尾,从第一个元素将尺尾不断后移开始找,当找到第一串符合条件的子序列后保存答案,再将尺头后移一位,重新查找并将查找到的答案与已有答案比较,直到尺头移到了最后一个元素或者尺尾已经到最后一个元素但是当前子序列和不足s为止。
代码:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
	int t,n,s,a[100001];
	cin>>t;
	while (t--)
	{
		cin>>n>>s;
		for (int i=1;i<=n;i++)
		scanf("%d",a+i);
		int l=1,r=1;
		int ans=2147483647,sum=0;
		while (l<=n)
		{
			while (sum<s && r<=n)
			{
				sum+=a[r];
				r++;
			}
			if (sum<s)
			break;
			if (r-l<ans) ans=r-l;
			sum-=a[l];
			l++;
		}
		if (ans>n) cout<<0<<endl;
		else
		cout<<ans<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值