杭电acm—1113 Word Amalgamation

Word Amalgamation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4353    Accepted Submission(s): 2195


Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words. 
 

Input
The input contains four parts: 

1. a dictionary, which consists of at least one and at most 100 words, one per line; 
2. a line containing XXXXXX, which signals the end of the dictionary; 
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique. 
 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

Sample Input
  
  
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
 

Sample Output
  
  
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1073  1075  1039  1088  1200 
     (提示:在杭电上面上交题目,如果是用C语言写的,尽量用G++提交,如果用c提交,可能会出现编译错误,本题就是最好的例子)
       这个题目呢,主要是考察我们对字符串的处理能力,用到的就是对字符串的排序问题,然而题目给的单词数不多,所以不用担心时间复杂度的问题,什么排序方法简单用什么,下面的代码,用的是选择法排序,比较的通俗易懂,还有一件事,注意格式,这很重要。
       AC的代码如下:(如有错误和建议,请大家不吝赐教)
#include<stdio.h>
#include<string.h>
void px(char str[]){//用选择排序 升序 
    int length=strlen(str);
    for(int i=0;i<length-1;i++){
        int index=i;
        for(int j=i+1;j<length;j++){
        if(str[index]>str[j])
           index=j;
       }
        char temp=str[index];
        str[index]=str[i];
        str[i]=temp;
    }  
}
int main(){
    char str[105][10];//定义两个二维数组 
    char str1[105][10];
    char x[10];
    int i=0;
    while(scanf("%s",str[i])!=EOF&&strcmp("XXXXXX",str[i])!=0){
       i++;
    }
    for(int j=0;j<i-1;j++){//按字典排序每一个字符串 ,方便后面的比较 
        int index=j;
        for(int k=j+1;k<i;k++){
        if(strcmp(str[index],str[k])>0)
           index=k;
        }
        char temp[10];
        strcpy(temp,str[j]);
        strcpy(str[j],str[index]);
        strcpy(str[index],temp);
    }
    for(int j=0;j<i;j++){
        strcpy(str1[j],str[j]); //复制 
        px(str1[j]);//每一个字符串里面,再次按升序排序 
    }
    while(scanf("%s",x)!=EOF&&strcmp("XXXXXX",x)!=0){
        px(x);//排序要找的单词 
        int flag=0;
        for(int j=0;j<i;j++){
        	if(strcmp(str1[j],x)==0)//比较 
        	   printf("%s\n",str[j]);
        	else
        	   flag++;
		}
		if(flag==i)
		  printf("NOT A VALID WORD\n");
		printf("******\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值