杭电acm—1376 Octal Fractions

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1376

Octal Fractions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 832    Accepted Submission(s): 386


Problem Description
Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.963125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point.

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals. The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k. Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]

where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.
 

Sample Input
  
  
0.75 0.0001 0.01234567
 

Sample Output
  
  
0.75 [8] = 0.953125 [10] 0.0001 [8] = 0.000244140625 [10] 0.01234567 [8] = 0.020408093929290771484375 [10]
 

Source
这一道题目,苦思冥想了很久,最后得到同学的点拨,一语惊醒梦中人,抓住一点,double是可以把后面的小数点计算出来的,只是输出的时候没有展现出来而已,所以,把小数点后的数字存储到字符数组里面就可以了。
AC代码如下:(如有错误和建议,请同学们不吝指出)
#include<stdio.h>
#include<string.h>	
#include<math.h> 
char str[1000];
char str10[1000];
int main(){
	while(scanf("%s",str)!=EOF&&strcmp(str,"0")){
		int len=strlen(str);
		double sum=0;
		int k=1;
		for(int i=2;i<len;i++){
			sum+=(str[i]-'0')*1.0/pow(8,k++);
		}
		k=0;
		while(sum){//sum为0时退出 
			str10[k]=(int)(sum*10)%10+'0';//把小数点后的数字存到数组 
			sum=sum*10-(str10[k]-'0');//减去已存的数字 
			k++;
		}
		str10[k]='\0';//注意这个不可无 
		printf("%s [8] = 0.%s [10]\n",str,str10);
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值