杭电acm—1009 FatMouse' Trade

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1009

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 80018    Accepted Submission(s): 27640


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

Author
CHEN, Yue
这是一个最基本的贪心问题了,位于杭电第一页第九个,可想而知他的代表性,水题一道
AC代码如下:(如有错误和建议,请大家不吝指出)
#include<stdio.h>
int main(){
	int m,n;
	int javaf[1000],catf[1000];
	double bz[1000];//定义一个数组存储比值
	while(scanf("%d%d",&m,&n)!=EOF&&(m!=-1||n!=-1)){
		int javafood=0,catfood=0;
		for(int i=0;i<n;i++){
			scanf("%d%d",&javaf[i],&catf[i]);
			javafood+=javaf[i];//把总量计算出来,方便后续操作
			catfood+=catf[i];
			if(catf[i]==0)//猫食为0时,不拿白不拿,比值无穷大
			  bz[i]=10000;
			else
			  bz[i]=javaf[i]*1.0/catf[i];
		}
		double add=0;
		if(catfood<=m){//如果m大于等于catfood,全部带走
			add=javafood;
			javafood=0;
		}
		while (javafood!=0&&m!=0){//当可以兑换的食物换完时或者自己的catf用完时,退出循环		
		    double max=-1;
		    int x;
			for(int i=0;i<n;i++){
				if(max<bz[i]){
				  max=bz[i];	
				  x=i;//存储最划算的下标
				}
			}
			if(m<=catf[x]){
				add+=max*m;
				m=0;
			}else{
				add+=javaf[x];
				javafood-=javaf[x];
				m=m-catf[x];
				bz[x]=-1;//注意换完了,作用也就没了,赋值-1
			}
		}
		printf("%.3lf\n",add);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值