Fibonacci Again(多次取模控制范围)

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

Author

Leojay

题目来源:http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1002&cid=32867
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int f[10000000];
int main()
{

    f[0]=7;
    f[1]=11;
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=2;i<=1000000;i++)
        {
            f[i]=(f[i-1]+f[i-2])%3%3%3;
        }
        if(f[n]==0)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
  为什么要取模三次:如果你这个数超出了int的范围接下来的%3就不准确了,
 你得在每次计算的时候让f(n)在int 范围内,因此要多次取模。

此题要点:多次取模使其不超过int的范围




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值