Problem F: Fibonacci Again

Problem F: Fibonacci Again

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 64   Solved: 18
[ Submit][ Status][ Web Board]

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n). Print the word "no" if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

HINT

这一题我写过的,但是在考场还是没有提交正确!一提交就是指


针越界,错的惨不忍睹,越着急越没用!当时我也知道是模运


算,但是还是没有提交正确,问题出在哪里了,我也不知道!

#include<stdio.h>
int main()
{
    int n,i,a,b,sum;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0||n==1)
        {
            printf("no\n");
        }
        else
        {
            a=7;b=11;
            for(i=2;i<=n;i++)
            {
                a%=3;
                b%=3;
                sum=(a+b)%3;
                a=b;
                b=sum;
            }
            if(sum==0)
            {
                printf("yes\n");
            }
            else
            {
                printf("no\n");
            }
        }
    }
}
我也没敢用数组存,害怕越界,不过还好AC了(那是在考场之


外)!我感觉我错误在i不是从2开始好像!记不清了!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值