1101 Quick Sort (25分)

1101 Quick Sort (25分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?
For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:
1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^5​​). Then the next line contains N distinct positive integers no larger than 10 ^​9​​. The numbers in a line are separated by spaces.
Output Specification:
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5

著名的快速排序算法中有一个称为分区的经典过程。在此过程中,我们通常选择一个元素作为支点。然后将小于枢轴的元素移到左侧,将大于枢轴的元素移到右侧。给定一个分区运行后有N个不同的正整数,您能否确定该分区选择的枢轴数是多少?
例如,给定N = 5且数字1、3、2、4和5。我们有:
1可能是枢轴,因为它的左侧没有元素,而其右侧的所有元素都大于它。
3一定不能成为枢轴,因为尽管左侧的所有元素都较小,但右侧的数字2也小于它。
2一定不能成为枢轴,因为尽管右侧的所有元素都较大,但左侧的数字3也比其大。并且出于类似的原因,4和5也可能是枢轴。
因此,总共有3个主要候选人。
输入规格:
每个输入文件包含一个测试用例。对于每种情况,第一行给出一个正整数N(≤10^5)。然后,下一行包含N个不大于10 ^ 9的正整数 。一行中的数字用空格分隔。
输出规格:
对于每个测试用例,在第一行中输出候选轴数。然后在下一行中按升序打印这些候选项。两个相邻数字之间必须恰好有1个空格,并且每行末尾不得有多余的空格。

#include<bits/stdc++.h>

using namespace std;

const int N=100010;

int n,num[N];
int L[N],R[N];
vector<int> s;

int main()
{
	cin >> n;
	
	for(int i=1;i<=n;i++) cin >> num[i];
	
	L[1] = num[1];
	R[n] = num[n];
	for(int i=2;i<=n;i++) L[i] = max(L[i-1],num[i]);
	for(int i=n-1;i>=1;i--) R[i] = min(R[i+1],num[i]);
	
	for(int i=1;i<=n;i++)
		if(L[i]==R[i] && L[i]==num[i]) {
			s.push_back(num[i]);
		}
		
 	sort(s.begin(),s.end());
 	
 	cout << s.size() << endl;
 	
 	for(int i=0;i<s.size();i++) {
 		cout << s[i] ;
 		if(i!=s.size()-1) cout << " ";
 	}
 	cout << endl;
	
	return 0;
}
  1. pivot的意思是枢轴,轴心,参照点的意思
  2. PAT的输出中多一行换行不算错,尽量带上换行。
  3. 这里第三个数据有点问题,轴心为0个时,要输出两行。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值