PTA 6-12 二叉搜索树的操作集 (重点记录删除节点)

目录

函数接口定义:

裁判测试程序样例:

输入样例:

输出样例:

满分提交结果:

节点删除的三种情况:

第一种情况:

第二种情况:

第三种情况:


  • 本题要求实现给定二叉搜索树的5种常用操作。

    函数接口定义:

    BinTree Insert( BinTree BST, ElementType X );
    BinTree Delete( BinTree BST, ElementType X );
    Position Find( BinTree BST, ElementType X );
    Position FindMin( BinTree BST );
    Position FindMax( BinTree BST );
  • 函数InsertX插入二叉搜索树BST并返回结果树的根结点指针;
  • 函数DeleteX从二叉搜索树BST中删除,并返回结果树的根结点指针;如果X不在树中,则打印一行Not Found并返回原树的根结点指针;
  • 函数Find在二叉搜索树BST中找到X,返回该结点的指针;如果找不到则返回空指针;
  • 函数FindMin返回二叉搜索树BST中最小元结点的指针;
  • 函数FindMax返回二叉搜索树BST中最大元结点的指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
    ElementType Data;
    BinTree Left;
    BinTree Right;
};

void PreorderTraversal( BinTree BT ); /* 先序遍历,由裁判实现,细节不表 */
void InorderTraversal( BinTree BT );  /* 中序遍历,由裁判实现,细节不表 */

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

int main()
{
    BinTree BST, MinP, MaxP, Tmp;
    ElementType X;
    int N, i;

    BST = NULL;
    scanf("%d", &N);
    for ( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Insert(BST, X);
    }
    printf("Preorder:"); PreorderTraversal(BST); printf("\n");
    MinP = FindMin(BST);
    MaxP = FindMax(BST);
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        Tmp = Find(BST, X);
        if (Tmp == NULL) printf("%d is not found\n", X);
        else {
            printf("%d is found\n", Tmp->Data);
            if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
            if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
        }
    }
    scanf("%d", &N);
    for( i=0; i<N; i++ ) {
        scanf("%d", &X);
        BST = Delete(BST, X);
    }
    printf("Inorder:"); InorderTraversal(BST); printf("\n");

    return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:

10
5 8 6 2 4 1 0 10 9 7
5
6 3 10 0 5
5
5 7 0 10 3

输出样例:

Preorder: 5 2 1 0 4 8 6 7 10 9
6 is found
3 is not found
10 is found
10 is the largest key
0 is found
0 is the smallest key
5 is found
Not Found
Inorder: 1 2 4 6 8 9

满分提交结果:

//将X插入二叉搜索树BST并返回结果树的根结点指针 
BinTree Insert( BinTree BST, ElementType X )
{
	if(BST == NULL){
		BST = (BinTree)malloc(sizeof(BinTree));
		BST->Data = X;
		BST->Left = NULL;
		BST->Right = NULL;
		return BST;
	}
	if(BST->Data > X)
		BST->Left = Insert(BST->Left,X);
	else if(BST->Data < X)
		BST->Right = Insert(BST->Right,X);
	return BST;
	
}
/*将X从二叉搜索树BST中删除,并返回结果树的根结点指针;
如果X不在树中,则打印一行Not Found并返回原树的根结点指针*/
BinTree Delete( BinTree BST, ElementType X )
{
	if(BST==NULL)	printf("Not Found\n");
	else if(BST->Data > X)	BST->Left = Delete(BST->Left,X);
	else if(BST->Data < X)	BST->Right = Delete(BST->Right,X);
	else{
		if(BST->Left == NULL)	return BST->Right;
		if(BST->Right == NULL)	return BST->Left;
		Position p = FindMax(BST->Left);
		p->Right = BST->Right;
		BST = BST->Left;
	}
	return BST;
	
}
//在二叉搜索树BST中找到X,返回该结点的指针;如果找不到则返回空指针
Position Find( BinTree BST, ElementType X )
{
	if(BST == NULL||BST->Data == X)
		return BST;
	else if(BST->Data > X)
		return Find(BST->Left,X);
	else
		return Find(BST->Right,X);
}
//返回二叉搜索树BST中最小元结点的指针
Position FindMin( BinTree BST )
{
	if(BST == NULL)
		return NULL;
	if(BST->Left!=NULL)
		return FindMin(BST->Left);
	else
		return BST;
}
//返回二叉搜索树BST中最大元结点的指针 
Position FindMax( BinTree BST )
{
	if(BST == NULL)
		return NULL;
	if(BST->Right!=NULL)
		return FindMax(BST->Right);
	else
		return BST;
}

 


节点删除的三种情况:

节点删除分三种情况,在本记录中按照样本数据介绍

第一种情况:

若为叶子节点,则可以直接删除,比如:0、4、7、9节点

代码为:

if(BST->Left == NULL)	return BST->Right;
if(BST->Right == NULL)	return BST->Left;
/*可理解为
if(BST->Left == NULL && BST->Right == NULL) return NULL;
*/

第二种情况:

若该节点仅有一个子节点,可直接将该子节点替代自己,比如:1、6、10

代码为:

if(BST->Left == NULL)	return BST->Right;
if(BST->Right == NULL)	return BST->Left;

第三种情况:

最复杂的一种情况,若有两个子节点,比如:5、2、8

该记录的解决方案为:将左子树中最大的叶子节点取代该节点位置,且其余结构不变

如下图删除5的操作:

1.将5删除       2.将方框移动至5的位置          3.将方框中最大值连接上8

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值