[POJ3070]Fibonacci

传送门POJ3070

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

Solution

  • 矩阵乘法&快速幂,原题已经有解释了….
  • 这一行是来凑字数的
  • 看上去充实一点
  • 其实就是个模板题

Code

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define ll long long
#define p 10000
using namespace std;
struct JOKER{
    ll e[2][2];
}a,b;
//直传数组的话数据规模大时容易TLE,结构体方便传递地址。
int n;
ll ans;
void matrix(JOKER &x,JOKER &y){
    JOKER z;
    memset(z.e,0,sizeof(z.e));
    for (int i=0;i<2;i++)
    for (int j=0;j<2;j++)
    for (int k=0;k<2;k++)
        z.e[i][j]=(z.e[i][j]+x.e[i][k]*y.e[k][j]%p)%p;
    for (int i=0;i<2;i++)
    for (int j=0;j<2;j++)
        y.e[i][j]=z.e[i][j];
}
int main(){
    while(true){
        scanf("%d",&n);
        if (n==-1) return 0;
        if (n==0){printf("0\n"); continue;}
        if (n<=1){printf("1\n"); continue;}
        a.e[0][0]=a.e[0][1]=a.e[1][0]=1;
        b.e[0][0]=b.e[0][1]=b.e[1][0]=1;
        a.e[1][1]=b.e[1][1]=0;
        int m=n-2;
        while (m){
            if (m&1) matrix(a,b);
            m>>=1; matrix(a,a);
        }
        ans=b.e[0][0]%p;
        printf("%lld\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值