9.4 PAT 甲级 1105 Spiral Matrix

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76
#include<iostream>
#include<algorithm>
#include<math.h>

using namespace std;

const int N = 10010;

int n;
int ipt[N], otpt[110][110];
bool st[110][110];

//寻找合适的列数
int find(int num)
{
    int t = sqrt(num);
    while(num % t != 0 && t >= 1)
        t --;
    return t;
}

bool cmp(int a, int b)
{
    return a > b;
}


int main()
{
    cin >> n;
    for(int i = 0; i < n; i ++ )    cin >> ipt[i];
    
    int col = find(n);
    int row = n / col;
    sort(ipt, ipt + n, cmp);

    
    //l表示行,m表示列
    int k = 0, l = 0, m = 0;
    while(k < n)
    {
        while(m < col && !st[l][m])
        {
            //cout << l << ' ' << m << ' ' << ipt[k] << endl;

            otpt[l][m] = ipt[k ++];
            st[l][m ++] = true;
        }
        m --, l ++;
        
        while(l < row && !st[l][m])
        {
           // cout << l << ' ' << m << ' ' << ipt[k] << endl;
            otpt[l][m] = ipt[k ++];
            st[l ++][m] = true;
        }
        l --, m --;
        
        while(m >= 0 && !st[l][m])
        {
           // cout << l << ' ' << m << ' ' << ipt[k] << endl;
            otpt[l][m] = ipt[k ++];
            st[l][m --] = true;
        }
        m ++, l --;
        
        while(l > 0 && !st[l][m])
        {
            //cout << l << ' ' << m << ' ' << ipt[k] << endl;
            otpt[l][m] = ipt[k ++];
            st[l --][m] = true;
        }
        l ++, m ++;
    }
    
    for(int i = 0; i < row; i ++)
    {
        cout << otpt[i][0];
        for(int j = 1; j < col; j ++)
            cout << ' ' << otpt[i][j];
        cout << endl;
    }
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值