This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.
Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
const int N = 10010;
int n;
int ipt[N], otpt[110][110];
bool st[110][110];
//寻找合适的列数
int find(int num)
{
int t = sqrt(num);
while(num % t != 0 && t >= 1)
t --;
return t;
}
bool cmp(int a, int b)
{
return a > b;
}
int main()
{
cin >> n;
for(int i = 0; i < n; i ++ ) cin >> ipt[i];
int col = find(n);
int row = n / col;
sort(ipt, ipt + n, cmp);
//l表示行,m表示列
int k = 0, l = 0, m = 0;
while(k < n)
{
while(m < col && !st[l][m])
{
//cout << l << ' ' << m << ' ' << ipt[k] << endl;
otpt[l][m] = ipt[k ++];
st[l][m ++] = true;
}
m --, l ++;
while(l < row && !st[l][m])
{
// cout << l << ' ' << m << ' ' << ipt[k] << endl;
otpt[l][m] = ipt[k ++];
st[l ++][m] = true;
}
l --, m --;
while(m >= 0 && !st[l][m])
{
// cout << l << ' ' << m << ' ' << ipt[k] << endl;
otpt[l][m] = ipt[k ++];
st[l][m --] = true;
}
m ++, l --;
while(l > 0 && !st[l][m])
{
//cout << l << ' ' << m << ' ' << ipt[k] << endl;
otpt[l][m] = ipt[k ++];
st[l --][m] = true;
}
l ++, m ++;
}
for(int i = 0; i < row; i ++)
{
cout << otpt[i][0];
for(int j = 1; j < col; j ++)
cout << ' ' << otpt[i][j];
cout << endl;
}
}