Marriage Ceremonies--Light OJ 1011

Marriage Ceremonies

题目位置:

Light OJ 1011

题目:

You work in a company which organizes marriages. Marriages are not that easy to be made, so, the job is quite hard for you.

The job gets more difficult when people come here and give their bio-data with their preference about opposite gender. Some give priorities to family background, some give priorities to education, etc.

Now your company is in a danger and you want to save your company from this financial crisis by arranging as much marriages as possible. So, you collect N bio-data of men and N bio-data of women. After analyzing quite a lot you calculated the priority index of each pair of men and women.

Finally you want to arrange N marriage ceremonies, such that the total priority index is maximized. Remember that each man should be paired with a woman and only monogamous families should be formed.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains an integer N (1 ≤ n ≤ 16), denoting the number of men or women. Each of the next N lines will contain N integers each. The jth integer in the ith line denotes the priority index between the ith man and jth woman. All the integers will be positive and not greater than 10000.

Output
For each case, print the case number and the maximum possible priority index after all the marriages have been arranged.

Sample Input
2
2
1 5
2 1
3
1 2 3
6 5 4
8 1 2
Sample Output
Case 1: 7
Case 2: 16

做法

做法1做法2做法3
暴力状压DP剪枝的DP
玄学错误!枚举状态加上了二进制的函数
WA,TLE,RETLEAC

就是想到了到了第i号男人的选定的时候,就是会有i-1位女嘉宾被选了!
所以在枚举状态的时候就是加上一个判断二进制 1 的个数的函数!
别的和普通状压DP是一样的!

数二进制有几个 1 :__builtin_popcount() 

代码

#include <bits/stdc++.h>
using namespace std;
#define N 18
int T,n,k;
int dp[N][1<<N],a[N][N];
int main()
{
    scanf("%d",&T);
    for(int loc=1; loc<=T; loc++)
    {
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                scanf("%d",&a[i][j]);
        int final=1<<n;
        for(int i=0;i<n;i++) dp[0][1<<i]=a[0][i];

        for(int i=1; i<n; i++)
            for(int used=0; used<final; used++)
                if(__builtin_popcount(used)==i)
                    for(int j=0; j<n; j++)
                    if(!(used & (1<<j)))
                    {
     dp[i][used|(1<<j)]=max(dp[i-1][used]+a[i][j],dp[i][used|(1<<j)]);
                    }
        printf("Case %d: %d\n",loc,dp[n-1][final-1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值