1150 Travelling Salesman Problem (25 分)

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

题意和分析: n个点、m条边,之后是m条边的数据,每条数据以a、b、d的形式给出,表示a和b之间的距离为d。探索路径有k条,每条先给出这条路径的点的数量,然后给出经过的各个点,(vector保存、set检查)输出有以下四种情况:

  • 相邻两点无通路——Path i: NA (Not a TS cycle)
  • 有通路,但是不是环(首尾相同)|| 经过的不同(set)的点的数不为n——Path i: d (Not a TS cycle)
  • 有通路,是环,但不是简单环(经过的点数k==n+1?)——Path i: d (TS cycle)
  • 简单环——Path i: d (TS simple cycle)

最后输出属于环(简单环or no)的最短路径的序号和长度(ansid,ans)

#include<bits/stdc++.h>
using namespace std;
int mp[205][205];
const int Inf=0x3f3f3f3f;
int n,flag,ansid,ans=Inf;
void Check(int x) {
	int k,sum=0;
	flag=0;
	scanf("%d",&k);
	vector<int> v(k+1);
	set<int> s;
	for(int i=1; i<=k; i++) {
		scanf("%d",&v[i]);
		s.insert(v[i]);
	}
	for(int i=1; i<k; i++) {
		if(mp[v[i]][v[i+1]]==Inf)
			flag=1;
		sum+=mp[v[i]][v[i+1]];
	}
	if(flag) { //相邻点走不通
		printf("Path %d: NA (Not a TS cycle)\n",x);
	} else if(v[1]!=v[k]||s.size()!=n) { //遍历所有点
		printf("Path %d: %d (Not a TS cycle)\n",x,sum);
	} else if(k!=n+1) {//所有节点只经过一次? 
		printf("Path %d: %d (TS cycle)\n",x,sum);
		if(ans>sum){
			ans=sum;
			ansid=x;
		}
	} else {
		printf("Path %d: %d (TS simple cycle)\n",x,sum);
		if(ans>sum){
			ans=sum;
			ansid=x;
		}
	}
}
int main() {
	int m,a,b,c,k;
	memset(mp,Inf,sizeof mp);
	scanf("%d %d",&n,&m);
	for(int i=1; i<=m; i++) {
		scanf("%d %d %d",&a,&b,&c);
		mp[a][b]=mp[b][a]=c;
	}
	scanf("%d",&k);
	for(int i=1; i<=k; i++)
		Check(i);
	printf("Shortest Dist(%d) = %d\n",ansid,ans);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值