1150 Travelling Salesman Problem (25 分)

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

 这道题,昨晚看了好久,不是题难,而是自己太菜,每次提交都是22分,昨晚坐在床上越看越迷糊,不知道哪里错了。直到今天重新审了下题,结果发现在not a ts cycle这里写错一个条件

Ts simple cycle:访问了每个城市,且仅存在一条简单的回路,起点等于终点

Ts cycle:访问了每个城市,但是存在多条回路,起点等于终点

not a ts cycle:并没有访问所有城市,或者并没有回到起点,

NA 只要给出的路,存在不通的情况,那就是NA,这个很好判断

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int mp[500][500];
int main(){
	int n,m;
	cin >> n >> m;
	for(int i = 1;i <= n;i++){
		for(int j = 0;j <= n;j++){
			mp[i][j] = 0;
		}
	}
	for(int i = 1;i <= m;i++){
		int a,b,d;
		cin >> a >> b >> d;
		mp[a][b] = mp[b][a] = d;
	}
	int k;
	cin >> k;
	int num = 0;
	int min = 999999;
	for(int i = 1;i <= k;i++){
		int sum = 0;
		int book[500];
		memset(book,0,sizeof(book)); 
		int l;
		int a[500];
		cin >> l;
		for(int j = 1;j <= l;j++){
			cin >> a[j];
			book[a[j]]++;
		}
		int cnt = 1;//标记是否全部的点被访问 
		int flag = 1;//标记是否有不存在的路 ,NA情况 
		for(int j = 1;j <= n;j++){
			 if(book[j] == 0){
			 	cnt = 0;
			 	break;
			 }
		}
		for(int j = 1;j < l;j++){
			if(mp[a[j]][a[j+1]]==0){
				flag = 0;
			}
			sum += mp[a[j]][a[j+1]];
		}
		if(flag == 0){
			printf("Path %d: NA (Not a TS cycle)\n", i);
		}else if(a[1] != a[l] || cnt == 0){
			printf("Path %d: %d (Not a TS cycle)\n", i, sum);
		}else if(l != n+1){
			printf("Path %d: %d (TS cycle)\n", i, sum);
			if(sum < min){
				min = sum;
				num = i;
			}
		}else{
			printf("Path %d: %d (TS simple cycle)\n", i, sum);
			if(sum < min){
				min = sum;
				num = i;
			}
		}
	}
	printf("Shortest Dist(%d) = %d\n",num,min);
	return 0;
}

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值