L3-1 二叉搜索树的结构 (30 分) (map+递归)

 

二叉搜索树或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值;若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值;它的左、右子树也分别为二叉搜索树。(摘自百度百科)

给定一系列互不相等的整数,将它们顺次插入一棵初始为空的二叉搜索树,然后对结果树的结构进行描述。你需要能判断给定的描述是否正确。例如将{ 2 4 1 3 0 }插入后,得到一棵二叉搜索树,则陈述句如“2是树的根”、“1和4是兄弟结点”、“3和0在同一层上”(指自顶向下的深度相同)、“2是4的双亲结点”、“3是4的左孩子”都是正确的;而“4是2的左孩子”、“1和3是兄弟结点”都是不正确的。

输入格式:

输入在第一行给出一个正整数N(≤100),随后一行给出N个互不相同的整数,数字间以空格分隔,要求将之顺次插入一棵初始为空的二叉搜索树。之后给出一个正整数M(≤100),随后M行,每行给出一句待判断的陈述句。陈述句有以下6种:

  • A is the root,即"A是树的根";
  • A and B are siblings,即"AB是兄弟结点";
  • A is the parent of B,即"AB的双亲结点";
  • A is the left child of B,即"AB的左孩子";
  • A is the right child of B,即"AB的右孩子";
  • A and B are on the same level,即"AB在同一层上"。

题目保证所有给定的整数都在整型范围内。

输出格式:

对每句陈述,如果正确则输出Yes,否则输出No,每句占一行。

输入样例:

5
2 4 1 3 0
8
2 is the root
1 and 4 are siblings
3 and 0 are on the same level
2 is the parent of 4
3 is the left child of 4
1 is the right child of 2
4 and 0 are on the same level
100 is the right child of 3

输出样例:

Yes
Yes
Yes
Yes
Yes
No
No
No
#include<bits/stdc++.h>
using namespace std;
int data[105],lef[105],rig[105],f[105]= {0},d[105]= {0};
void find(int &r,int pos,int fa,int dp) {//最终返回root为1 
	if(r==-1) {
		r=pos; 
		f[pos]=fa;//下标pos的father为fa 
		d[pos]=dp;//下标pos的depth 为dp
		return;
	} else if(data[pos]>data[r]) find(rig[r],pos,r,dp+1);
	else if(data[pos]<data[r]) find(lef[r],pos,r,dp+1);
}
int main() {
	int n,m,root=-1;
	memset(lef,-1,sizeof lef);
	memset(rig,-1,sizeof rig);
	map<int,int> mp;
	cin>>n;
	for(int i=1; i<=n; i++) {
		cin>>data[i];
		mp[data[i]]=i;//map记录该值在数组中的位置 
		find(root,i,-1,1);//从第二个数据开始root=1 
	}
	int a,b;
	string s;
	cin>>m;
	while(m--) {
		int flag=0;
		cin>>a>>s;
		if(s=="is") {
			cin>>s>>s;
			if(s=="root") {
				if(mp[a]!=0&&f[mp[a]]==-1) flag=1;
			} else if(s=="parent") {
				cin>>s>>b;
				if(mp[a]!=0&&mp[b]!=0&&f[mp[b]]==mp[a]) flag=1;
			} else if(s=="left") {
				cin>>s>>s>>b;
				if(mp[a]!=0&&mp[b]!=0&&lef[mp[b]]==mp[a]) flag=1;
			} else if(s=="right") {
				cin>>s>>s>>b;
				if(mp[a]!=0&&mp[b]!=0&&rig[mp[b]]==mp[a]) flag=1;
			}
		} else if(s[0]=='a') {
			cin>>b>>s>>s;
			if(s[0]=='o') {
				cin>>s>>s>>s;
				if(mp[a]!=0&&mp[b]!=0&&d[mp[a]]==d[mp[b]]) flag=1;
			} else if(s[0]=='s')
				if(mp[a]!=0&&mp[b]!=0&&f[mp[a]]==f[mp[b]]) flag=1;
		}
		if(flag) cout<<"Yes\n";
		else cout<<"No\n";
	}
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值