1047:
printf("%s\n",vs[i][j].c_str());//不用%s会超时
map+set is ok
Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.
Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.
Sample Input:
10 5 ZOE1 2 4 5 ANN0 3 5 2 1 BOB5 5 3 4 2 1 5 JOE4 1 2 JAY9 4 1 2 5 4 FRA8 3 4 2 5 DON2 2 4 5 AMY7 1 5 KAT3 3 5 4 2 LOR6 4 2 4 1 5
Sample Output:
1 4 ANN0 BOB5 JAY9 LOR6 2 7 ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6 3 1 BOB5 4 7 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1 5 9 AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
题意:给出选课人数和课程数目,然后再给出每个人的选课情况,请针对每门课程输出选课人数以及所有选该课的学生姓名,按照字典序
#include<bits/stdc++.h>
using namespace std;
vector<string> vs[2505];
int main() {
int n,k,x,m;
string name;
cin>>n>>k;
while(n--) {
cin>>name>>m;
while(m--) {
scanf("%d",&x);
vs[x].push_back(name);
}
}
for(int i=1; i<=k; i++) {
sort(vs[i].begin(),vs[i].end());
printf("%d %d\n",i,vs[i].size());//0也要输出!
for(int j=0; j<vs[i].size(); j++)
printf("%s\n",vs[i][j].c_str());//不用%s会超时
}
return 0;
}
1039:
- 变长的vector、hash——26*26*26*10+10 (name 规范时适用)
- map+set
类似于 1022 https://mp.csdn.net/postedit/100011922
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (≤200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5 4 7 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1 1 4 ANN0 BOB5 JAY9 LOR6 2 7 ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6 3 1 BOB5 5 9 AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1 ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5 ANN0 3 1 2 5 BOB5 5 1 2 3 4 5 JOE4 1 2 JAY9 4 1 2 4 5 FRA8 3 2 4 5 DON2 2 4 5 AMY7 1 5 KAT3 3 2 4 5 LOR6 4 1 2 4 5 NON9 0
题意:有N个学生,K门课,给出选择每门课的学生姓名,最后对于给出的N个学生的姓名的选课情况进行询问,要求按顺序给出每个学生的选课情况
思路:string、cin、cout会超时故用hash(26*26*26*10+10)将学生姓名变为int型,然后存储在vector里面
#include<bits/stdc++.h>
using namespace std;
int get_id(char *name){
int id=0;
for(int i=0;i<3;i++)
id=id*26+(name[i]-'A');
id=id*10+(name[3]-'0');
return id;
}
const int maxn=26*26*26*10+10;
vector<int> v[maxn];
int main() {
int n,k,cno,num,id;
char name[10];
scanf("%d%d",&n,&k);//n个人,k门考试
for(int i=0;i<k;i++){
scanf("%d%d",&cno,&num);//考试号为cno,参加该考试的共num个人
while(num--){
scanf("%s",name);
id=get_id(name);
v[id].push_back(cno);//hash存储
}
}
for(int i=0;i<n;i++){
scanf("%s",name);
id=get_id(name);
sort(v[id].begin(),v[id].end());
printf("%s %d",name,v[id].size());
for(int j=0;j<v[id].size();j++)
printf(" %d",v[id][j]);
printf("\n");
}
return 0;
}
#include<iostream>
#include<map>
#include<set>
#include<string>
#include<algorithm>
using namespace std;
//选好容器很重要
map<string,set<int> > mp;
int main() {
int n,k,cno,num;
char ch[5];
cin>>n>>k;
for(int i=0;i<k;i++){
scanf("%d%d",&cno,&num);
while(num--){
scanf("%s",ch);
mp[ch].insert(cno);
}
}
for(int i=0;i<n;i++){
scanf("%s",ch);
printf("%s",ch);
printf(" %d",mp[ch].size());
for(auto it=mp[ch].begin();it!=mp[ch].end();it++)
printf(" %d",*it);
printf("\n");
}
return 0;
}