【ZOJ2476】Total Amount(字符串模拟大数相加)

题目链接

Total Amount


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Given a list of monetary amounts in a standard format, please calculate the total amount.

We define the format as follows:

1. The amount starts with '$'.

2. The amount could have a leading '0' if and only if it is less then 1.

3. The amount ends with a decimal point and exactly 2 following digits.

4. The digits to the left of the decimal point are separated into groups of three by commas (a group of one or two digits may appear on the left).


Input

The input consists of multiple tests. The first line of each test contains an integer N (1 <= N <= 10000) which indicates the number of amounts. The next N lines contain N amounts. All amounts and the total amount are between $0.00 and $20,000,000.00, inclusive. N=0 denotes the end of input.


Output

For each input test, output the total amount.


Sample Input

2
$1,234,567.89
$9,876,543.21
3
$0.01
$0.10
$1.00
0


Sample Output

$11,111,111.10
$1.11

 

解题思路:

其实题目本身不难但是要注意细节。

1.数据范围很大一定要用字符串,因为字符串加减不方便,所以这里把字符转存到整数数组里相加

2.还要特判一下两个数相加后整数部分没有0的情况。

3.加,的位置和PAT甲级第一题很像,稍微找一下规律。

 

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e+5+5;
char a[maxn];
int c[maxn],d[maxn],ans[maxn];
int main()
{
    int T;
    while(~scanf("%d",&T) && T)
    {
        memset(ans,0,sizeof(ans));
        memset(d,0,sizeof(d));
        int index,cnt=0;
        while(T--)
        {
            memset(c,0,sizeof(c));
            memset(a,0,sizeof(a));
            scanf("%s",a);
            int k=0;
            for(int i=0;i<strlen(a);i++)
            {
                if(isdigit(a[strlen(a)-i-1]))
                    c[k++]=a[strlen(a)-i-1]-'0';
            }
            for(int i=0;i<100;i++)
            {
                d[i]+=c[i];
                d[i+1]+=d[i]/10;
                d[i]%=10;
            }
        }
        for(int i=100;i>=0;i--)
        {
            if(d[i]!=0)
            {
                index=i;
                break;
            }
        }
        for(int i=index;i>=2;i--)
            ans[cnt++]=d[i];
        printf("$");
        if(cnt==0)printf("0");
        else
        {
            for(int i=0;i<cnt;i++){
                printf("%d",ans[i]);
                if((cnt-i-1)%3==0 && i!=cnt-1)
                    printf(",");
            }
        }

        printf(".%d%d\n",d[1],d[0]);
    }
    return 0;
}
/*
2
$2.45
$3.56
*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值