【ZOJ2042】Divisibility(dp)

题目链接


Divisibility


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions:

17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 

We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.


Input

The first line of the input contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 

The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value.


Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input

2

4 7
17 5 -21 15

4 5
17 5 -21 15


Sample Output

Divisible 

Not divisible

 

【题意】

给定n个数,中间可以添加“+”或“-”,判断这n个数的组合是否能被k整除。

【解题思路】

dp[i][j]:前i个数模k的余数为j。

因为一个数模k后只可能是0-k-1,所以写一个for循环,如果前i-1个数的余数j存在的话,再加上这次的num[i],当然如果是减的话需要加k避免出现负数,所以最后只需要判断前n个数余数为0的状态是否存在,若存在则输出Divisible。

【代码】

#include<bits/stdc++.h>
using namespace std;
int dp[10005][100],num[10005];
int main()
{
    int T;
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            memset(dp,0,sizeof(dp));
            int n,k,x;
            scanf("%d%d",&n,&k);
            for(int i=0;i<n;i++)
            {
                scanf("%d",&x);
                if(x>0)num[i]=x%k;
                else num[i]=((-x)%k);
            }
            dp[0][num[0]]=1;
            for(int i=1;i<n;i++)
            {
                for(int j=0;j<k;j++)
                {
                    if(dp[i-1][j])
                    {
                        dp[i][(j+num[i])%k]=1;
                        dp[i][(j-num[i]+k)%k]=1;
                    }
                }
            }
            if(dp[n-1][0])printf("Divisible\n");
            else printf("Not divisible\n");
            if(T)printf("\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值