POJ 330 Radar Installation|贪心法

题目描述

总时间限制: 1000ms  内存限制: 65536kB

描述

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations

输入

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

输出

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

样例输入

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

样例输出

Case 1: 2
Case 2: 1

问题解决

没做作业前听了老师讲的思路,就一脉相承的做了这个思路的解决方法QAQ

一个比较巧妙的地方是,在输入数据的时候,首先将其坐标转化为在x轴上的一个区间,也就是说雷达要覆盖这个岛,就只能装在这个范围内。

然后将问题转化为【点对区间的覆盖】的问题,使用贪心法解决,将所有区间按起点排序,然后遍历一遍,每遇到一个新的区间,分为两种情况:

1.下一个区间完全在现有区间之外——结果加一,现有区间更新为下一个区间

2.下一个区间和现有区间有交集——将现有区间更新为现有区间与该区间的交集

#include <iostream>
#include <algorithm>
using namespace std;

struct range{
    double l,r;
}ranges[1005];

bool cmp(range x,range y){
    return x.l<y.l;
}

int main(){
    int n,d,cnt=1;
    while(cin>>n>>d){
        if (n==0 & d==0) break;
        int x,y,res=1;
        for(int i=0;i<n;i++){
            cin>>x>>y;
            if(y>d) res=-1;
            else{
                ranges[i].l=x-sqrt(d*d-y*y);
                ranges[i].r=x+sqrt(d*d-y*y);
            }
        }
        if(res==-1){
            cout<<"Case "<<cnt++<<": "<<res<<endl;
            continue;
        }
        sort(ranges,ranges+n,cmp);
        double start=ranges[0].l,end=ranges[0].r;
        for(int i=1;i<n;i++){
            if(ranges[i].l>end){
                start=ranges[i].l;
                end=ranges[i].r;
                res++; 
            }else {
                start=ranges[i].l;
                end=min(ranges[i].r,end);
            }
        }
        cout<<"Case "<<cnt++<<": "<<res<<endl;
    }
    return 0;
}

最最最坑的地方是,千万不能给变量int!比如我的start和end一不小心给了int,找了好久才找出来错TUT

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值