POJ 862 Currency Exchange|Bellman-Ford|环检测

题目描述

总时间限制: 1000ms内存限制: 65536kB

描述

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

输入

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

输出

If Nick can increase his wealth, output YES, in other case output NO to the output file.

样例输入

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

样例输出

YES

问题解决

主要使用bellman-ford算法进行环检测,如果在n-1轮操作后仍然可以进行松弛操作,则说明有环存在。

#include <iostream>
#include<cstring>
using namespace std;
struct exchange_point{
int a,b;
double  r;
double c;
};
//从a->b换钱,税率为r,佣金为c
double dis[101];
//兑换后每种货币的数目。
int n;
//货币的总数
int m;
//兑换点的数目
int s;
//初始货币的种类
double v;
//初始货币的数目
int all;
//all所有兑换点的数目
//这里定义的兑换点单向的
//因此一个兑换点包含两个"兑换点"
exchange_point ex[202];
bool bellman()
{
    memset(dis,0,sizeof(dis));
    //因为要找正向环,所以初始化时设置货币值为零
    dis[s]=v;//s点的数目已经找到了
    //初始化v
    bool flag;
    //记录是否更新
    int i,j;
    for(i=1;i<=n-1;i++)
    {
        flag=false;
        for(j=0;j<all;j++)
            if(dis[ex[j].b]<(dis[ex[j].a]-ex[j].c)*ex[j].r){
                dis[ex[j].b]=(dis[ex[j].a]-ex[j].c)*ex[j].r;
                flag=true;
                }//本轮更新了
                if(!flag)break;//没有更新则说明更新结束了
    }//先做完松弛操作
    //只有正向环还能继续“松弛”
    //找正向环
    for(int k=0;k<all;k++)
    {
        if(dis[ex[k].b]<(dis[ex[k].a]-ex[k].c)*ex[k].r)
            return true;
    }
    return false;
}
int main()
{
    int a,b;
    int i,j;
    double rab,cab,rba,cba;
    while(cin>>n>>m>>s>>v)
    {
        all=0;
        for(i=0;i<m;i++)
        {
            cin>>a>>b>>rab>>cab>>rba>>cba;
            ex[all].a=a;
            ex[all].b=b;
            ex[all].r=rab;
            ex[all++].c=cab;
            ex[all].a=b;
            ex[all].b=a;
            ex[all].r=rba;
            ex[all++].c=cba;
        }
        if(bellman())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值