大整数相加

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 436008    Accepted Submission(s): 84836


 

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

 

Sample Input

 

2 1 2 112233445566778899 998877665544332211

 

 

Sample Output

 

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 

 

 

 

方法一:

#include <iostream>
#include<stdio.h>
#include<string.h>
const int MAX=1001;
using namespace std;

int max(int a,int b) {
    return a>b?a:b;
}

class SeqList {
public:
    int data[MAX];
    int length;
public:
    SeqList() {
        length=0;
        memset(data,0,sizeof(data));
    }
    SeqList(char str[]) {

        this->length=strlen(str);
        int count=0;
        for(int i=length-1; i>=0; i--) {
            data[count++]=str[i]-'0';
        }
    }

    void Print() {

        for(int i=length-1; i>=0; i--)
            cout<<data[i];

    }
};
SeqList Add(SeqList& A,SeqList& B) {
    SeqList C;
    int n=A.length;
    int m=B.length;
    int flag=0,i=0;
    while(i<m&&i<n) {
        C.data[i]=(A.data[i]+B.data[i]+flag)%10;
        flag=(A.data[i]+B.data[i]+flag)/10;
        i++;
    }
    while(i<n) {
        C.data[i]=(A.data[i]+flag)%10;
        flag=(flag+A.data[i])/10;
        i++;
    }
    while(i<m) {
        C.data[i]=(B.data[i]+flag)%10;
        flag=(flag+B.data[i])/10;
        i++;
    }

    C.length=max(n,m)+flag;

    if(flag==1)
        C.data[C.length-1]=1;
    return C;
}
int main() {

    char str[1001],str1[1001];
    int T;
    while(cin>>T) {
        int count=0;
        while(T--) {

            scanf("%s%*c%s",str,str1);
            SeqList A(str),B(str1);
            SeqList ret;
            ret=Add(A,B);
            if(count)
                cout<<endl;
            cout<<"Case "<<count+1<<":"<<endl;
            cout<<str<<" + "<<str1<<" = ";
            ret.Print();
            cout<<endl;
            count++;

        }

    }
    return 0;
}

方法二:

#include <iostream>
#include<stdio.h>
#include<string.h>
#define MAX 1001
using namespace std;

template<class T>
class SeqList {
public:
    T data[MAX];
    int length;
    SeqList(char *s) {
        length=strlen(s);
        int count=0;
        memset(data,0,sizeof(data));
        for(int i=length-1; i>=0; i--)
            data[count++]=s[i]-'0';
    }
    SeqList() {
        length=0;
    }
    void Print() {
        for(int i=length-1; i>=0; i--) {
            cout<<data[i];
        }
    }
};

SeqList<int >  Add( SeqList<int >  A,  SeqList<int > B) {
    SeqList<int> c;
    int len_A=A.length;
    int len_B=B.length;
    int len_max=len_A>len_B?len_A:len_B;
    c.length=len_max;
    memset(c.data,0,sizeof(c.data));
    for(int i=0; i<len_max; i++) {
        c.data[i]+=A.data[i]+B.data[i];
        if(c.data[i]>=10) {
            c.data[i]-=10;
            c.data[i+1]+=1;
        }
    }
    if(c.data[len_max]!=0)
        c.length++;
    return c;
}
int main() {
    char a[1001],b[1001];
    int T;
    while(cin>>T) {
        int count=0;
        while(count<T) {
            if(count!=0)
                cout<<endl;
            cout<<"Case "<<(count+1)<<":"<<endl;
            scanf("%s%s",a,b);
            SeqList<int> A(a),B(b);
            A.Print();
            cout<<" + ";
            B.Print();
            cout<<" = ";
            SeqList<int> ret=Add(A,B);

            ret.Print();
            cout<<endl;
            count++;
        }
    }



    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

haibianyoushark

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值