9041:判括号匹配

23 篇文章 0 订阅

Problem Description

任意输入一个由若干个圆括号、方括号和花括号组成的字符串,设计一个算法判断该串中的括号是否配对。

 Input

有多组数据,每组为一个包含3类括号的字符串,串长不超过100。

 Output

若该串中的括号匹配输出1,否则输出0。

 Sample Input

([{}])
([{}})
([{)]}

 Sample Output

1
0
0
#include <iostream>
#include<stdio.h>
#include<string.h>
const int MAX=101;
using namespace std;

class Stack {
public:
    int top;
    char data[MAX];
public:
    Stack() {
        top=-1;
    }

    void push(int c) {
        if(top!=MAX-1) {
            data[++top]=c;
        }
    }

    char pop() {
        int c='\0';
        if(top!=-1) {
            c=data[top--];
        }
        return c;
    }
    char getTop() {
        if(top!=-1)
            return data[top];
        else
            return -999;
    }
    bool isEmpty() {
        return top==-1?true:false;
    }
    void print() {
        for(int i=0; i<top+1; i++)
            cout<<data[i]<<" ";
        cout<<endl;
    }
};

int main() {
  
    char str[MAX];
    while(cin>>str) {
        Stack stack;
        int flag=1;
        int i=0;
        int n=strlen(str);

        while(i<n&&flag) {
            if(str[i]=='{'||str[i]=='('||str[i]=='[') {
                stack.push(str[i]);

            } else {
                switch(str[i]) {
                case ')':

                    if(stack.top==-1||stack.pop()!='(')flag=0;
                    break;
                case ']':

                    if(stack.top==-1||stack.pop()!='[')flag=0;
                    break;
                case '}':

                    if(stack.top==-1||stack.pop()!='{')flag=0;
                    break;
                }
            }
            i++;
        }
        if(stack.top!=-1)flag=0;
        if(flag)
            cout<<"1"<<endl;
        else
            cout<<"0"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

haibianyoushark

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值