C语言实验——一元二次方程Ⅰ

C语言实验——一元二次方程Ⅰ
Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description

解一元二次方程ax2+bx+c=0的解。保证有解

Input

a,b,c的值。

Output

两个根X1和X2,其中X1>=X2。 结果保留两位小数。

Example Input

1 5 -2

Example Output

0.37 -5.37

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
double x1 = 0,x2 = 0;
void jisuan(double a,double b,double c)
{
    double d = b*b-4*a*c,t;
    if(d>0)
    {
        x1 = (-b+sqrt(d))/(2*a);
        x2 = (-b-sqrt(d))/(2*a);
        if(x1<x2)
        {
            t = x1;
            x1 = x2;
            x2 = t;
        }
        printf("%.2lf %.2lf\n",x1,x2);
    }
    else if(d==0)
    {
        x1 = x2 = -b/(2*a);
        printf("%.2lf %.2lf\n",x1,x2);
    }
}
int main()
{
    double a,b,c;
    scanf("%lf %lf %lf",&a,&b,&c);
    jisuan(a,b,c);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值