PAT练习1001

PAT练习日记
#1001 A+B Format
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​^6 ≤a,b≤10^6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

#正确答案
#涉及函数abs(求绝对值) 注意区分数的范围,最大为七位数,所以可根据划分几个逗号来分类
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
int main(){
int a,b,sum,c;
sum = 0;
scanf("%d %d",&a,&b);
sum = a+b;
if(sum<1000&&sum>-1000){
printf("%d",sum);
}else{
if(sum<1000000&&sum>-1000000){
printf("%d,%03d",sum/1000,abs(sum%1000));
}else{
c = abs(sum%1000000);
printf("%d,%03d,%03d",sum/1000000,c/1000,c%1000);
}
}
system(“pause”);
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值