刷题记录
算是第一篇记录刷题的博客吧,打了ACM一年了,没有这个习惯。。。
最近在准备PAT甲级,顺便记录一下坑(PAT的坑真的无fuck可说,数据范围也不给,题意又。。。。)
1014 Waiting in Line (30分)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.
At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.
Input
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.
Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
1
2
3
Sample Output
08:07
08:06
08:10
17:00
Sorry
题目大意:
银行排队办理业务,有n个窗口,每个窗口前有黄线,黄线内最多排m个人,剩下的人在黄线外等候
给出k个人,并给出他们办理业务所需要的时间time,查询p个人的办理业务结束时间,如果开始办理业务时超过了17:00,输出sorry
08:00开始办理业务,17:00结束办理业务,如果业务已经开始办理,就继续办理直到办理业务结束窗口才关门。
如果某个窗口有人办理业务结束,黄线外的人去那个窗口的队尾等候,如果两个窗口同时有人办理业务结束,就选择窗口号较小的
做法:
无非就是在选择队伍的时候选择最短且最靠前的队伍,选完后无法再次换队伍。
这样维护好每个队伍,每次取每个队伍的队头剩余服务时间最少的人,时间跳转到其服务结束后,然后如果维护的黄线队列里面如果还有人就把它插到该队伍。
就是有点麻烦+恶心。
无语的是:所谓的 Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.居然是17:00开始不服务,而不是服务进行到17:00就会停止。这样强制加班真的好吗????????????服务员心里mmp,我也mmp
其次在知道了上面的前提下。还改了40分钟,很久没有这么被模拟题卡了,可能是太久没写了。
心态着实有点崩了,直接改到没时间,cf去了。
代码:
#include<bits/stdc++.h>
using namespace std;
#define mp make_pair
#define pr pair<int,int>
pr ti[20][20];
int cou[20];
int ans[1001];
int be[1001];
int main()
{
int n, m;
int k, q;
cin >> n >> m >> k >> q;
int i;
queue<pr> que;
for (i = 0; i < k; i++)
{
int t;
cin >> t;
if (i < n * m)
{
ti[i % n][i / n].first = t;
ti[i % n][i / n].second = i;
be[i] = 0;
cou[i % n]++;
}
else que.push(mp(t, i));
}
int now = 0;
while (k)
{
int mi = INT_MAX;
for (i = 0; i < n; i++)
{
if (mi > ti[i][0].first && cou[i])
{
mi = ti[i][0].first;
}
}
//cout << now << endl;
now += mi;
for (i = 0; i < n; i++)
{
if (cou[i])ti[i][0].first -= mi;
if (!ti[i][0].first && cou[i])
{
k--;
ans[ti[i][0].second] = now;
int j;
for (j = 0; j < cou[i] - 1; j++)
{
ti[i][j] = ti[i][j + 1];
}
if (que.size())ti[i][j] = que.front(), que.pop();
else cou[i]--;
if(cou[i])be[ti[i][0].second] = now+1;
}
}
}
while (q--)
{
int w;
cin >> w;
w--;
if (be[w]<=540)printf("%02d:%02d\n", ans[w] / 60 + 8, ans[w] % 60);
else cout << "Sorry" << endl;
}
return 0;
}