PAT 1129 Recommendation System

17 篇文章 0 订阅

1129 Recommendation System (25分)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

 这道题,单看英文确实题意确实不太好理解,最后根据样例才把这道题看懂……

题目大意:

实现一个简单的推荐系统的功能。用户在看第一个的时候不推荐任何数字,因为之前没有看过任何数字。之后,推荐的数字按照用户之前看过的数字的个数来推荐,次数大的优先输出,如果次数一样,那么数字小的优先输出。

第一行给出的n和k分别表示查看数字的总次数,和推荐数字的最多个数(一次最多推荐k个)。

 

解决方法:利用结构体和set。结构体实现数据的封装,利用set对数据排序,修改数据的次数也很方便。

#include <bits/stdc++.h>
#define Max 55555
using namespace std;
struct node{
	int num, cnt;
	node(int num,int cnt):num(num),cnt(cnt){}
	bool operator < (const node &a) const{
		return cnt != a.cnt ? cnt > a.cnt : num < a.num;
	}
};
set<node> s;
int times[Max], n, k, num;
int main(){
	memset(times, 0, sizeof(times));
	cin >> n >> k;
	
	for(int i = 0; i < n; i++){
		cin >> num;
		if(i != 0){
			cout << num << ":";
			int cnt = 0;
			set<node> ::iterator it;
			for(it = s.begin(); cnt < k && it!=s.end(); it++){
				cout << " " << (*it).num;
				cnt++;
			}
			cout << endl;
		}
		set<node> ::iterator it;
		it = s.find(node(num,times[num]));
		if(it != s.end()) s.erase(it);
		times[num]++;//更新浏览次数 加入set中
		s.insert(node(num,times[num])); 
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值