PAT 1127 ZigZagging on a Tree (30分)

20 篇文章 0 订阅
13 篇文章 0 订阅

1127 ZigZagging on a Tree (30分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题目大意:给出中序后序,让你输出层序序列(蛇形的)

思路:中序后序——>建树,再将层次遍历的结点(包含值,下标,层数)存入vector中,利用sort排序 ,当前层是奇数层,从小到大,偶数层从大到小就这样排,最后输出

//给出中序遍历+后序遍历
//让你输出层序遍历(从上到下,从左到右,从右到左z) 
//偶数层  从右到左 
//奇数层  从左到右 
#include <bits/stdc++.h>
using namespace std;

struct node{
	int val;
	int ind, lev;
	node(int v, int i, int l):val(v), ind(i), lev(l){}
};
int in[101], post[101], n; 
vector<node> vec;
bool cmp(node a, node b) {
	if(a.lev != b.lev) return a.lev < b.lev;
	if(a.lev % 2 == 0) return a.ind > b.ind;
	return a.ind < b.ind;
}
void dfs(int rt, int l, int r, int index, int level) {
	if(l > r) return ;
	int i = l;
	while(l <= r && in[i] != post[rt]) i++;
	vec.push_back(node(post[rt], index, level));
	dfs(rt - 1 - (r - i), l, i - 1, index*2+1, level+1);
	dfs(rt - 1, i + 1, r, index*2+2, level+1);
}
int main() {
	cin >> n;
	for(int i = 0; i < n; i++)
		cin >> in[i];
	for(int i = 0; i < n; i++)
		cin >> post[i]; 
	dfs(n - 1, 0, n-1, 0 , 0);
	sort(vec.begin(), vec.end(), cmp);
	for(int i = 0; i < vec.size(); i++) {
		cout << vec[i].val;
		if(i != vec.size() - 1) cout << " ";
		else cout << endl;
	} 
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值