判断一个大数是不是6的倍数(水题)

Description

求 N 是不是6的倍数,输出YES 或 no
8.jpg

Input

多组测试样例

第一行输入T(T<10000) 表示T组样例

接下来每行输入一个整数N (0<=N<=10^10000)

Output

是6的倍数输出 YES ,否则输出 no

Sample Input 1 

3
1
6
12

Sample Output 1

no
YES
YES

Sample Input 2 

2
0
45641534135468416344135441356489643185674356485643564865456457634

Sample Output 2

YES
YES



     
     
因为是大数 所以刚开始 把这道题想歪了。。。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char s[25000];
int main()
{
	int t;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		gets(s);
		int len=strlen(s);
		if((s[len-1]-'0')%2!=0)
		{
			printf("no\n");
			continue;
		}
		int ans=0;
		for(int i=0;i<len;i++)
		{
			ans+=(s[i]-'0');
		}
		if(ans%3==0)
		{
			printf("YES\n");
		}else printf("no\n");
	}return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值