03-树2 List Leaves (25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

答案:

#include<stdio.h>
#include<stdlib.h>
#include <stdbool.h> 

//树按从上到下,从左到右输出叶子结点 
#define Null -1 

//思路:建立一个循环队列,从根结点 开始入队, 
//队列不为空则出队一个结点,然后入队它的左右结点 直至队列为空(层序遍历) 
// 如果出队的是叶子结点,则输出 

//循环队列
typedef struct QNode *PtrToQNode;
struct QNode{
	int *Data;
	int front,rear;
	int MaxSize;
}; 
typedef PtrToQNode Queue;

Queue CreateQueue(int MaxSize){
	Queue Q=(Queue)malloc(sizeof(struct QNode));
	Q->Data=(int*)malloc(MaxSize*sizeof(int));
	Q->front=Q->rear=0;
	Q->MaxSize=MaxSize;
	return Q;
}

//队满:(rear+1)%数组长度==front 
bool IsFull(Queue Q){
	return ((Q->rear+1)%Q->MaxSize==Q->front);
}
//队空: rear==front
bool IsEmpty(Queue Q){
	return (Q->rear==Q->front);
} 
//入队
bool AddQ(Queue Q,int x){
	if(IsFull(Q)){
		return false;
	}else{
		Q->rear=(Q->rear+1)%Q->MaxSize;
		Q->Data[Q->rear]=x;
		return true;
	}
} 
//出队
int DeleteQ(Queue Q){
	if(IsEmpty(Q)){
		return Null; 
	}else{
		Q->front=(Q->front+1)%Q->MaxSize;
		return (Q->Data[Q->front]);
	}
}


//树 
struct TreeNode{
	int left;
	int right;
}T[10]; 

//建立一颗树,返回根结点 
int BuildTree(struct TreeNode T[]){
	
	int Root=Null,i,N,check[10];
	char cl,cr;
	scanf("%d\n",&N);
	if(N){
		for(i=0;i<N;i++) check[i]=0;
		for(i=0;i<N;i++){
		   scanf("%c %c\n",&cl,&cr);	
		   
		   if(cl!='-'){
		   	T[i].left=cl-'0';
		   	check[T[i].left]=1;
		   }else{
		   	T[i].left=Null;
		   }
		   
		   if(cr!='-'){
		   	T[i].right=cr-'0';
		   	check[T[i].right]=1; 
		   }else{
		   	T[i].right=Null;
		   }	   
		}
		
		//判断哪个是根结点 
		for(i=0;i<N;i++){
			if(!check[i])break;
		} 
		Root=i;
	}
	//printf("kkkkk%d\n",Root);
	return Root;
}

//层次遍历,输出叶子结点 
void PrintLeaves(int R){
	int TT;//当前出队的结点 
	Queue Q=CreateQueue(10);
	if(R==Null){//空树 
		return;
	}else{
		AddQ(Q,R);
	}
	
	while(!IsEmpty(Q)){
		TT=DeleteQ(Q);
		if(T[TT].left==Null&&T[TT].right==Null){//叶子结点 
			printf("%d",TT);
            if(!IsEmpty(Q))printf(" ");
		} else{//非叶子结点 
			if(T[TT].left!=Null){
				AddQ(Q,T[TT].left);
			}
			if(T[TT].right!=Null){
				AddQ(Q,T[TT].right);
			}
		}
	}
	
	
} 

int main(){
  int R;
  R=BuildTree(T);
  PrintLeaves(R);	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值