动态规划:poj-1837 Balance

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 
Input
The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 
Output
The output contains the number M representing the number of possibilities to poise the balance.
Sample Input
2 4	
-2 3 
3 4 5 8
Sample Output
2

题目大意:根据力臂的数组和砝码数组的值来计算是否是平衡的,用二维数组dp[i][j]表示加上第i个砝码到达的j,i只有达到n,而且j等于0的时候才能是平衡的,所以最后的答案就是dp[n][0],但是因为数组下标j不能为负数,所以用15*20*15=7500来替代0,就是当dp[n][7500]才是答案。

AC代码:

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int l[25];
int m;
int n;
int w[25];
int dp[25][16000]; //意思是上了i个砝码到达到j。
int main()
{
	cin >> n >> m;
	memset(dp, 0, sizeof(dp));
	dp[0][7500] = 1;
	for (int i = 1; i <= n; i++)
		cin >> l[i];
	for (int j = 1; j <= m; j++)
		cin >> w[j];
	for (int i = 1; i <= m; i++)
	{
		for (int j = 15000; j >=0; j--)
		{
			for (int k = 1; k <= n; k++)
			{
				dp[i][j + w[i] * l[k]]+=dp[i-1][j];
			}
		}
	}
	cout << dp[m][7500] << endl;
	return 0;
}
dp真的是。。。要多练习
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值