POJ - 1837 Balance (DP——背包问题)

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1…25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
Input
The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15…15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1…25 representing the weights’ values.
Output
The output contains the number M representing the number of possibilities to poise the balance.
Sample Input
2 4
-2 3
3 4 5 8
Sample Output
2

题意

一个天平,两边最多各有15个可以挂砝码的位置,砝码数量最多20个且质量各不相同。现给出挂钩位置和砝码质量,问有多少种方案能使天平平衡,必须用上所有的砝码。

分析

特别注意:最极端的情况是所有物体都挂在最远端,因此平衡度最大值为15*20*25=7500。
原则上就应该有dp[ 0..20 ][-7500 ..  7500 ]。因此做一个处理,使得数组开为 dp[0.. 20][0..15000]

这道题用到了一个物理知识:力臂=重量 *臂长 = b[i]*a[k]。

有一个天平,天平左右两边各有若干个钩子,总共有C个钩子,有G个钩码,求将钩码全部挂到钩子上使天平平衡的方法的总数。

其中可以把天枰看做一个以x轴0点作为平衡点的横轴,当平衡度k=0时,说明天枰达到平衡,k>0,说明天枰倾向右边(x轴右半轴),k<0则左倾,因此可以定义一个 状态数组dp[i][k],意为在挂满前i个钩码时,平衡度为k的挂法的数量。由于距离c [ i ]的范围是-15~ 15,钩码重量的范围是1~25,钩码数量最大是20.因此最极端的平衡度是所有物体都挂在最远端,因此平衡度最大值为j=152025=7500。原则上就应该有dp[ 1~20 ][-7500 ~ 7500 ]。因此为了不让下标出现负数,做一个处理,使使得数组开为 dp[1~20][ 0~15000],则当j=7500时天枰为平衡状态。

状态方程为 :

dp[i][k]+=dp[i-1][k-b[i]*a[j]];
#include <stdio.h>
#include <string.h>
int dp[25][15010];
int a[1000],b[1000];
int main()
{
    int i,j,n,m,sum,k;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for (i=1;i<=n;i++)
        	scanf("%d",&a[i]);//代表位置
        for (j=1;j<=m;j++)
        	scanf("%d",&b[j]);//代表重量
        dp[0][7500]=1;//放入0个物品时,就已经是平衡点
      for (i=1;i<=m;++i)
        	for (j=1;j<=n;j++)
        		for (k=0;k<=15000;k++)
        			dp[i][k]+=dp[i-1][k-b[i]*a[j]];//表示这个状态的方法数=先前得到的方法数+上个状态的方法数
        printf ("%d\n",dp[m][7500]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

沐雨风栉

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值