PAT 自测-4 Have Fun with Numbers Java实现

问题描述

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

问题分析

这个问题要熟练掌握BigInteger的各种方法,还要想到通过把其转化成字符串的形式处理每一位数。通过charAt() - '0’的方法使字符变为数字。

代码实现

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        BigInteger x = sc.nextBigInteger();
        BigInteger y = x.multiply(BigInteger.valueOf(2));
        String before = x.toString();
        String after = y.toString();
        System.out.println(Judge(before,after)? "Yes":"No");
        System.out.println(after);
    }

    public static boolean Judge(String before, String after){
        int[] arr = new int[10]; //默认都为0
        int num;
        if (before.length() != after.length()) return false;
        //遍历before 计算现有数值
        for (int i = 0; i < before.length(); i++) {
            num = before.charAt(i) - '0';   //找到数字几,就存在下标为几的数组空间内
            arr[num]++;
        }

        //遍历翻倍里面的数字
        for (int i = 0; i < after.length(); i++) {
            num = after.charAt(i) - '0';   //找到数字几,就存在下标为几的数组空间内
            arr[num]--;
        }

        //若数组中元素都为零,则符合要求
        for (int i = 0; i < arr.length; i++) {
            if (arr[i] != 0)    return false;
        }
        return  true;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值