Have Fun with Numbers(简易C语言)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
思路:
先用字符数组存放原先的数字,用整形数组存放每个数字出现的次数。
计算每一位的时候,先转化为整型,将该数字出现的次数+1.
乘2之后,将结果数字个位数出现的次数-1,判断是否进位。
如果原数字第一位乘2再加上第二位数字进位1,大于10,则不符条件。
详情参考代码,如下:

#include<stdio.h>
#include<string.h>

int main()
{
	char s[20];                      //字符数组整数字符串
	int a[10]={0};                   //a[i]存放数字i出现的次数,初始为0;					
	scanf("%s",s);
	
	int len=strlen(s),f=0,i;        //f判断是否进位; 
	
	for(i=len-1;i>=0;i--)
	{
		int k;
		k=s[i]-'0';                 //k表示字符串数组中第i位的数字,字符型整数数组元素-'0'变为整型整数 
		a[k]++;	
	
		s[i]=(char)((k*2+f)%10+'0'); //乘2后字符串数组的值要改变
		
		a[(k*2+f)%10]--;             //减去乘2后数字出现的次数
		if((k*2+f)>=10)																	
		{
			f=1;
		}	
		else f=0;
	}
	if(f==1)                         //最后位数超过原来的位数时
	{
		printf("No\n");
		printf("%c%s",'1',s);		//先输出进位的1,再输出后面的字符串数组 
	}
	else
	{
		for(i=0;i<10;i++)
		{
			if(a[i]!=0)             //当乘2后的数字出现变化时
			{
				printf("No\n%s",s);break;
			}
		}
		if(i==10)          
		{
			printf("Yes\n%s",s);
		}
	}
	
	return 0;
}

  • 2
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值