Common Subsequence dp

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest 
abcd           mnp
Sample Output
4
2
0
题意:给定两个字符串,求其最长公共子串。其中子串不必是连续的,即ac是abc的子串。
用dp[i][j]来表示a串前i个字符与b串前j个字符的公共子串最长长度。
状态转移方程:
如果a[i]==b[j]  dp[i][j]=dp[i-1][j-1]+1; 因为a[i]和b[j]是相等的,所以长度就是dp[i-1][j-1]加一就行
如果a[i]!=b[j]  dp[i][j]=max(dp[i-1][j],dp[i][j-1]); 因为a[i]和b[j]是不相等的,所以现在的最长就是a的前i-1在b的前j的最长和a的前i在b的前j-1的最长中的较大值。
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int dp[1000][1000];
int main() {
	string a,b;
	while(cin>>a>>b) {
		int La,Lb;
		La=a.size() ;
		Lb=b.size() ;
		int Max=0;
		memset(dp,0,sizeof(dp));
		for(int i=0; i<a.size(); i++) {
			for(int j=0; j<b.size(); j++) {
				if(a[i]==b[j]) {
					if(i>0&&j>0)
						dp[i][j]=dp[i-1][j-1]+1;
					else
						dp[i][j]=1;
				}
				if(a[i]!=b[j]) {
					if(i>0&&j>0)
						dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
					else if(i>0)
						dp[i][j]=dp[i-1][j];
					else if(j>0)
						dp[i][j]=dp[i][j-1];

				}
				Max=max(Max,dp[i][j]);
			}
		}
		cout<<Max<<endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值