UESTC Training for Summer selection C

C · m-ary Partitions

A partition of an integer n is a set of positive integers whichsum to n, typically written indescending order. For example:

 

10 = 4+3+2+1

 

A partition is m-ary ifeach term in the partition is a power of m.For example, the 3-ary partitions of 9 are:

9

3+3+3

3+3+1+1+1

3+1+1+1+1+1+1

1+1+1+1+1+1+1+1+1

 

Write aprogram to find the number of m-arypartitions of an integer n.

 

Input

 

Thefirst line of input contains a single decimal integer P, (1 £ P £ 1000), which is thenumber of data sets that follow. Each data set should be processed identicallyand independently.

 

Each data set consists of a single line of input. The line containsthe data set number, K, followed by the base of powers, m, (3<= m <= 100), followed by a space, followed by the integer,

n, (3 <= n <= 10000), for which the number of m-ary partitions is to be found.

 

Output

 

Foreach data set there is one line of output. The output line contains the dataset number, K, a space, and the number of m-ary partitions of n.The result should fit in a 32-bit unsigned integer.

 

Sample Input

Sample Output

5

1 3 9

2 3 47

3 5 123

4 7 4321

5 97 9999

1 5

2 63

3 75

4 144236

5 111

题意:给定 n,m,求n 的 m元划分。
思路:dp。

dp[ n ][ k ]表示 和为 n ,最大不超过 m^k 的划分方案;

转移方程: dp[ n ][ k ]=dp[ n ][ k-1 ]+dp[ n -m^k ][ k ].

就是完全背包的变形。

然后用滚动数组优化:

dp[ n ]=dp[ n ]+dp[ n- k ];

记得初始化时候, dp[ n ]=1,因为n 总可以分成 n 个 1 。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
#define maxn 200005
#define inf 0x3f3f3f3f
#define ii 0x3f
const int mod = 1001113;


ll read() {
	ll x = 0, f = 1;
	char ch = getchar();
	while (ch < '0' || ch > '9') {
		if (ch == '-') {
			f = -1;

		}
		ch = getchar();
	}
	while (ch >= '0'&&ch <= '9') {
		x = x * 10 + ch - '0';
		ch = getchar();
	}
	return x * f;
}

ll quickpow(ll a, ll b) {
	ll ans = 1;
	while (b > 0) {
		if (b % 2)ans = ans * a;
		b = b / 2;
		a = a * a;
	}
	return ans;
}
//char s[maxn];

int gcd(int a, int b) {
	return b == 0 ? a : gcd(b, a%b);
}

int dp[maxn];
int main() {
	ios::sync_with_stdio(false);
	int t;
	cin >> t;
	while (t--) {
		memset(dp, 0, sizeof(dp));
		int a, b, n;
		cin >> a >> b >> n;
		int maxx = 0;
		while (quickpow(b, maxx + 1) <= n)maxx++;
		for (int i = 0; i <= n; i++) {
			dp[i] = 1;
		}
		for (int i = 1; i <= maxx; i++) {
			int q = quickpow(b, i);
			for (int j = q; j <= n; j++) {
				dp[j] = dp[j] + dp[j - q];
			}
		
		}
		cout << a << ' ' << dp[n] << endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
互联网络程序设计是指在互联网上进行程序开发和设计的过程。UESTC则是我国的一所著名高校——电子科技大学。 互联网络程序设计 uestc包含了两个主要的方面:互联网络和程序设计。互联网络是指将多个计算机网络通过通信链路互相连接起来,实现信息共享和资源共享的网络系统。程序设计是指根据需求和目标,通过编写代码和设计算法,实现计算机程序的过程。 互联网络程序设计 uestc的学习内容主要包括以下几个方面: 1. 网络知识:学习互联网络的基本概念、原理和协议,如TCP/IP协议、HTTP协议等。掌握网络编程的基本技术,能够编写网络应用程序。 2. 数据通信:学习数据通信的基本原理和技术,包括数据传输的方式、数据压缩和加密等。了解网络安全和数据保护的基本知识。 3. 程序设计:学习编程语言和开发工具,如Java、C++和Python等。掌握常用的编程技巧和方法,能够设计和实现复杂的网络应用程序。 4. Web开发:学习Web开发的基本知识和技术,包括HTML、CSS、JavaScript等。能够设计和实现交互式的Web应用程序。 5. 数据库技术:学习数据库的基本原理和技术,如SQL语言和数据库管理系统。能够设计和管理数据库,实现数据的存储和检索。 通过学习互联网络程序设计 uestc,可以掌握互联网应用开发的基本技能,具备设计和实现网络应用程序的能力。这对于目前互联网行业的人才需求来说是非常重要的,也为学生提供了广阔的就业和创业机会。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值