UESTC Training for summer selection E

本质就是逆序对的问题;

考虑动态规划求解:

考虑 dp[ i ] [ j ].

表示 i 个数排列 逆序对个数为 j 时 的方案数;

转移方程: dp[ i ][ j ]= dp[ i-1 ][ j ]*(j+1)  +  dp[ i-1 ][ j-1 ]*(i-j)。

初始化时 dp[ i ][ 0 ]=1;


Given a positiveinteger, N, a permutation oforder N is a one-to-one (and thus onto)function from the set of integers from 1to N to itself. If p is such a function, we representthe function by a list of its values:

 

[ p(1p(2) … p(N)]

 

For example,

 

[5 6 2 4 7 1 3] represents the function from { 1 … 7 } to itself which takes 1to 5, 2 to 6, … , 7 to 3.

 

Forany permutation p, a descent of p isan integer k for which p(k) > p(k+1).For example, the permutation [5 6 24 7 1 3] has a descent at 2 (6 > 2) and 5 (7 > 1).

 

Forpermutation p, des(p) is the number of descents in p. For example, des([5 6 2 4 7 1 3]) = 2. The

identity permutation isthe only permutation with des(p) = 0. The reversing permutation with

p(k) = N+1-k is the only permutation with des(p) = N-1.

 

The permutation descent count (PDC)for given order N and value v is the number of permutations p

of order N withdes(p)= v.For example:

 

PDC(3, 0) = 1 { [ 1 2 3 ] }

PDC(3, 1) = 4 { [ 1 3 2 ], [ 2 1 3 ], [ 2 3 1 ], 3 1 2 ] }

PDC(3, 2) = 1 { [ 3 2 1 ] }

 

Write a program to compute the PDCfor inputs N and v. To avoid having to deal with verylarge numbers, your answer (and your intermediate calculations) will becomputed modulo 1001113.

 

Input

 

The first lineof input contains a single integer P, (1 £ P £ 1000), which is thenumber of data sets that follow. Each data set should be processed identicallyand independently.

 

Each data set consists of a single line of input. It contains thedata set number, K, followed by the integer order, N (2 £ N £ 100), followed by aninteger value, v (0 £ v £ N-1).

 

Output

 

For each dataset there is a single line of output. The single output line consists of thedata set number, K, followed by a single space followed by the PDC of N and v modulo 1001113 as a decimal integer.


 

Sample Input

Sample Output

4

1 3 1

2 5 2

3 8 3

4 99 50

1 4

2 66

3 15619

4 325091

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
#define maxn 2005
#define inf 0x3f3f3f3f
#define ii 0x3f
const int mod = 1001113;




ll read() {
ll x = 0, f = 1;
char ch = getchar();
while (ch < '0' || ch > '9') {
if (ch == '-') {
f = -1;


}
ch = getchar();
}
while (ch >= '0'&&ch <= '9') {
x = x * 10 + ch - '0';
ch = getchar();
}
return x * f;
}


ll quickpow(ll a, ll b) {
ll ans = 1;
while (b > 0) {
if (b % 2)ans = ans * a;
b = b / 2;
a = a * a;
}
return ans;
}
//char s[maxn];


int gcd(int a, int b) {
return b == 0 ? a : gcd(b, a%b);
}


int p, k, n, v;
int dp[maxn][maxn];
void js() {
memset(dp, 0, sizeof(dp));
dp[2][1] = 1;
dp[2][0] = 1;
for (int i = 3; i <= 100; i++) {
dp[i][0] = 1;
for (int j = 1; j < i - 1; j++) {
dp[i][j] = (dp[i - 1][j] * (j + 1) + dp[i - 1][j - 1] * (i - j)) % mod;
}
dp[i][i - 1] = 1;
}
}
int main() {
ios::sync_with_stdio(false);
js();
cin >> p;
while (p--) {
cin >> k >> n >> v;
cout << k << ' ' << dp[n][v] << endl;
}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
互联网络程序设计是指在互联网上进行程序开发和设计的过程。UESTC则是我国的一所著名高校——电子科技大学。 互联网络程序设计 uestc包含了两个主要的方面:互联网络和程序设计。互联网络是指将多个计算机网络通过通信链路互相连接起来,实现信息共享和资源共享的网络系统。程序设计是指根据需求和目标,通过编写代码和设计算法,实现计算机程序的过程。 互联网络程序设计 uestc的学习内容主要包括以下几个方面: 1. 网络知识:学习互联网络的基本概念、原理和协议,如TCP/IP协议、HTTP协议等。掌握网络编程的基本技术,能够编写网络应用程序。 2. 数据通信:学习数据通信的基本原理和技术,包括数据传输的方式、数据压缩和加密等。了解网络安全和数据保护的基本知识。 3. 程序设计:学习编程语言和开发工具,如Java、C++和Python等。掌握常用的编程技巧和方法,能够设计和实现复杂的网络应用程序。 4. Web开发:学习Web开发的基本知识和技术,包括HTML、CSS、JavaScript等。能够设计和实现交互式的Web应用程序。 5. 数据库技术:学习数据库的基本原理和技术,如SQL语言和数据库管理系统。能够设计和管理数据库,实现数据的存储和检索。 通过学习互联网络程序设计 uestc,可以掌握互联网应用开发的基本技能,具备设计和实现网络应用程序的能力。这对于目前互联网行业的人才需求来说是非常重要的,也为学生提供了广阔的就业和创业机会。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值