UESTC Training for summer selection E

本质就是逆序对的问题;

考虑动态规划求解:

考虑 dp[ i ] [ j ].

表示 i 个数排列 逆序对个数为 j 时 的方案数;

转移方程: dp[ i ][ j ]= dp[ i-1 ][ j ]*(j+1)  +  dp[ i-1 ][ j-1 ]*(i-j)。

初始化时 dp[ i ][ 0 ]=1;


Given a positiveinteger, N, a permutation oforder N is a one-to-one (and thus onto)function from the set of integers from 1to N to itself. If p is such a function, we representthe function by a list of its values:

 

[ p(1p(2) … p(N)]

 

For example,

 

[5 6 2 4 7 1 3] represents the function from { 1 … 7 } to itself which takes 1to 5, 2 to 6, … , 7 to 3.

 

Forany permutation p, a descent of p isan integer k for which p(k) > p(k+1).For example, the permutation [5 6 24 7 1 3] has a descent at 2 (6 > 2) and 5 (7 > 1).

 

Forpermutation p, des(p) is the number of descents in p. For example, des([5 6 2 4 7 1 3]) = 2. The

identity permutation isthe only permutation with des(p) = 0. The reversing permutation with

p(k) = N+1-k is the only permutation with des(p) = N-1.

 

The permutation descent count (PDC)for given order N and value v is the number of permutations p

of order N withdes(p)= v.For example:

 

PDC(3, 0) = 1 { [ 1 2 3 ] }

PDC(3, 1) = 4 { [ 1 3 2 ], [ 2 1 3 ], [ 2 3 1 ], 3 1 2 ] }

PDC(3, 2) = 1 { [ 3 2 1 ] }

 

Write a program to compute the PDCfor inputs N and v. To avoid having to deal with verylarge numbers, your answer (and your intermediate calculations) will becomputed modulo 1001113.

 

Input

 

The first lineof input contains a single integer P, (1 £ P £ 1000), which is thenumber of data sets that follow. Each data set should be processed identicallyand independently.

 

Each data set consists of a single line of input. It contains thedata set number, K, followed by the integer order, N (2 £ N £ 100), followed by aninteger value, v (0 £ v £ N-1).

 

Output

 

For each dataset there is a single line of output. The single output line consists of thedata set number, K, followed by a single space followed by the PDC of N and v modulo 1001113 as a decimal integer.


 

Sample Input

Sample Output

4

1 3 1

2 5 2

3 8 3

4 99 50

1 4

2 66

3 15619

4 325091

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
#define maxn 2005
#define inf 0x3f3f3f3f
#define ii 0x3f
const int mod = 1001113;




ll read() {
ll x = 0, f = 1;
char ch = getchar();
while (ch < '0' || ch > '9') {
if (ch == '-') {
f = -1;


}
ch = getchar();
}
while (ch >= '0'&&ch <= '9') {
x = x * 10 + ch - '0';
ch = getchar();
}
return x * f;
}


ll quickpow(ll a, ll b) {
ll ans = 1;
while (b > 0) {
if (b % 2)ans = ans * a;
b = b / 2;
a = a * a;
}
return ans;
}
//char s[maxn];


int gcd(int a, int b) {
return b == 0 ? a : gcd(b, a%b);
}


int p, k, n, v;
int dp[maxn][maxn];
void js() {
memset(dp, 0, sizeof(dp));
dp[2][1] = 1;
dp[2][0] = 1;
for (int i = 3; i <= 100; i++) {
dp[i][0] = 1;
for (int j = 1; j < i - 1; j++) {
dp[i][j] = (dp[i - 1][j] * (j + 1) + dp[i - 1][j - 1] * (i - j)) % mod;
}
dp[i][i - 1] = 1;
}
}
int main() {
ios::sync_with_stdio(false);
js();
cin >> p;
while (p--) {
cin >> k >> n >> v;
cout << k << ' ' << dp[n][v] << endl;
}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值