HDU2899Strange fuction (三分)应该也可以二分

Now, here is a fuction: 
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) 
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

对函数求导,发现函数在0-100区间内先递减后递增

采用三分,我才用先二分然后在3/4处三分

也可以二分对导数,找导数为0的点,在代入原函数,求得最小值

import java.util.Scanner;

public class Main {
	static int T;
	static double Y;
	
	static double jisuan(double x){
		return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-Y*x;
	}
	
	static double jisuan1(){
		double left=0,right=100;
		double mid=0,mmid;
		while((right-left)>1e-9){
			mid=(left+right)/2;
			mmid=(mid+right)/2;
			if(jisuan(mid)<jisuan(mmid))//大于小于区间确定要认真考虑
				right=mmid;
			else
				left=mid;
		}
		return jisuan(mid);
	}
	
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc=new Scanner(System.in);
		T=sc.nextInt();
		while(T>0){
			Y=sc.nextDouble();
			
			double m=jisuan1();
			System.out.println(String.format("%.4f",m));
			T--;
		}
	}

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值