1044 火星数字 (20 分)

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

思路:

1.测试点1是输入0的时候,注意此时高位低位都为0,需要特判

2.如果是13的倍数不输出tret

3.输入记得getchar()吞掉回车

感想:这题第一次做用字符数组,简直是折磨,这次用字符串做感觉还好,需要考虑的情况比较多,不过也是提交了好几次才过。

#include <bits/stdc++.h>

using namespace std;

string e[13]={"tret","jan","feb","mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string h[13]={"","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};

void MarsNum(string s)
{
    int num=atoi(s.c_str());
    int hi,l;
    l=num%13;
    hi=num/13;
    if(hi&&l)               //!i表示i==0,i表示i!=0
        cout<<h[hi]<<' '<<e[l]<<endl;
    else if(!hi&&l)
        cout<<e[l]<<endl;
    else if(hi&&!l)
        cout<<h[hi]<<endl;  //如果是13的倍数
    else
        cout<<e[0]<<endl;   //如果是0
}

void EarthNum(string s)
{
    int hi=0,l=0,i=0;
    string sh,sl;
    i=s.find(' ');      //find未找到返回-1
    if(i>0)
    {
        sh=s.substr(0,i);
        sl=s.substr(i+1,s.length()-1);
        for(int i=0;i<13;i++)
        {
            if(h[i]==sh)
                hi=i;
            if(e[i]==sl)
                l=i;
        }
        cout<<hi*13+l<<endl;
    }
    else
    {
        for(int j=0;j<13;j++)
        {
            if(h[j]==s)
                hi=j;
            if(e[j]==s)
                l=j;
        }
        cout<<hi*13+l<<endl;
    }

}

int main()
{
    int n;
    cin>>n;
    getchar();          //注意回车
    for(int i=0;i<n;i++)
    {
        string s;
        getline(cin,s);
        if(isdigit(s[0]))
            MarsNum(s);
        else
            EarthNum(s);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值