ospf tunnel 联合建网

R1,R7,R8为公网

R10pingR6环回

R10tracerouteR6环回

R2:

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key 6 ccie address 0.0.0.0 0.0.0.0
crypto ipsec transform-set ccie esp-3des esp-md5-hmac 
 mode transport
crypto ipsec profile ccie
 set transform-set ccie 
interface Loopback0
 ip address 172.16.2.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.0.1 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 ip ospf network broadcast
 ip ospf priority 100
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccie
!
interface FastEthernet0/0
 ip address 12.0.0.2 255.255.255.0
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 192.168.0.0 0.0.0.255 area 0
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

R3

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key 6 ccie address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ccie esp-3des esp-md5-hmac 
 mode transport
!
crypto ipsec profile ccie
 set transform-set ccie 
!
crypto ipsec profile ccnp
 set transform-set ccie 
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
 ip address 172.16.3.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.0.2 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map 192.168.0.1 12.0.0.2
 ip nhrp map multicast 12.0.0.2
 ip nhrp network-id 100
 ip nhrp nhs 192.168.0.1
 ip nhrp shortcut
 ip nhrp redirect
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccie
!
interface Tunnel1
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 ip nhrp redirect
 ip ospf network broadcast
 tunnel source 3.3.3.3
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccnp
!
interface FastEthernet0/0
 ip address 13.0.0.2 255.255.255.0
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 172.16.3.0 0.0.0.255 area 0
 network 192.168.0.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

R4

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key 6 ccie address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ccie esp-3des esp-md5-hmac 
 mode transport
!
crypto ipsec profile ccie
 set transform-set ccie 
!
crypto ipsec profile ccnp
 set transform-set ccie
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface Loopback1
 ip address 172.16.4.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.0.3 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map 192.168.0.1 12.0.0.2
 ip nhrp map multicast 12.0.0.2
 ip nhrp network-id 100
 ip nhrp nhs 192.168.0.1
 ip ospf network broadcast
 ip nhrp shortcut
 ip nhrp redirect
 ip ospf priority 0
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccie
!
interface Tunnel1
 ip address 192.168.2.1 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 ip nhrp redirect
 ip ospf network broadcast
 tunnel source Loopback0
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccnp
interface FastEthernet0/0
 ip address 14.0.0.2 255.255.255.0
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 172.16.4.0 0.0.0.255 area 0
 network 192.168.0.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

R5

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key 6 ccie address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ccie esp-3des esp-md5-hmac 
 mode transport
!
crypto ipsec profile ccnp
 set transform-set ccie 
interface Loopback0
 ip address 172.16.5.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.1.3 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map 192.168.1.1 3.3.3.3
 ip nhrp map multicast 3.3.3.3
 ip nhrp network-id 100
 ip nhrp nhs 192.168.1.1
 ip nhrp shortcut
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccnp
!
interface FastEthernet0/0
 ip address 57.0.0.2 255.255.255.0
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 172.16.5.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

R6

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key 6 ccie address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ccie esp-3des esp-md5-hmac 
 mode transport
!
crypto ipsec profile ccnp
 set transform-set ccie
interface Loopback0
 ip address 172.16.6.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.1.2 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map 192.168.1.1 3.3.3.3
 ip nhrp map multicast 3.3.3.3
 ip nhrp network-id 100
 ip nhrp nhs 192.168.1.1
 ip nhrp shortcut
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source FastEthernet1/0
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccnp
interface FastEthernet1/0
 ip address 67.0.0.2 255.255.255.0
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 network 172.16.6.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 FastEthernet1/0

R9

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key 6 ccie address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ccie esp-3des esp-md5-hmac 
 mode transport
!
crypto ipsec profile ccie
 set transform-set ccie 
interface Loopback0
 ip address 172.16.9.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.2.2 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map 192.168.2.1 4.4.4.4
 ip nhrp map multicast 4.4.4.4
 ip nhrp network-id 100
 ip nhrp nhs 192.168.2.1
 ip nhrp shortcut
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccie
!
interface FastEthernet0/0
 ip address 89.0.0.2 255.255.255.0
router ospf 1
 router-id 9.9.9.9
 log-adjacency-changes
 network 172.16.9.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

R10

crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
crypto isakmp key 6 ccie address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set ccie esp-3des esp-md5-hmac 
 mode transport
!
crypto ipsec profile ccie
 set transform-set ccie 
!
interface Loopback0
 ip address 172.16.10.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.2.3 255.255.255.0
 no ip redirects
 ip nhrp authentication 123
 ip nhrp map 192.168.2.1 4.4.4.4
 ip nhrp map multicast 4.4.4.4
 ip nhrp network-id 100
 ip nhrp nhs 192.168.2.1
 ip nhrp shortcut
 ip ospf network broadcast
 ip ospf priority 0
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 1
 tunnel protection ipsec profile ccie
!
interface FastEthernet0/0
 ip address 81.0.0.2 255.255.255.0
 duplex half

router ospf 1
 router-id 10.10.10.10
 log-adjacency-changes
 network 172.16.10.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值