PAT 1108 Finding Average(20 分) (有限状态自动机)

题目内容

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

注释:

今天刷pat的时候遇到这道题,编译原理里的有限状态自动机

本题的状态转换图:


num表示数字
‘-’表示负号
‘.’表示小数点
other表示除以上三种的其它字符
any表示任意字符
圆圈里的数字表示状态,初态为0,6为不合法的状态,一旦到达该状态立刻认定此数不合法;2、3(以3状态结束表示小数点后面没数字,经测试本题认定是合法的)、4、5是合法终态;如果在状态1结束是非法的,因为只有一个负号。

源代码:

#include<bits/stdc++.h> 

using namespace std;

/*
状态转移矩阵
	num	- . other
0	2	1 6	6
1	2   6 6 6
2	2	6 3 6
3	4	6 6 6
4	5	6 6	6
5	6 	6 6 6
*/

int mx[6][4] = {2,1,6,6,
				2,6,6,6,
				2,6,3,6,
				4,1,6,6,
				5,6,6,6,
				6,6,6,6};

int mp(char c) //将字符映射为列索引
{
	if(c >= '0' && c <= '9') return 0;
	if(c == '-') return 1;
	if(c == '.') return 2;
	return 3;
}

double n;

bool is_legal(string s)
{
	int cur_state = 0; //初态为0
	for(int i = 0;i < s.size();i ++)
	{
		char c = s[i];
		cur_state = mx[cur_state][mp(c)]; //状态转移
		if(cur_state == 6) return false;
	}
	if(cur_state == 1) return false;
	else
	{
		stringstream stream; //字符串转数字
		stream<<s;
		stream>>n;
		if(n >= -1000 && n <= 1000) return true;
		else return false;
	}
}

int main()
{
	int N,count = 0;
	double sum = 0;
	cin>>N;
	string s;
	for(int i = 0;i < N;i ++)
	{
		cin>>s;
		if(is_legal(s))
		{
			sum += n;
			count ++;	
		}
		else cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
	}
	if(count == 0) cout<<"The average of 0 numbers is Undefined";
	else if(count == 1) printf("The average of 1 number is %.2f",sum);
	else printf("The average of %d numbers is %.2f",count,sum / count);
	return 0;
}

提交结果

在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Finding bugs(寻找错误)是指在软件开发过程,为了保证软件的质量和稳定性,通过一系列的测试和调试过程,找出软件存在的错误和缺陷,并进行修复的活动。 寻找错误是软件开发过程必不可少的一步。在软件开发过程,无论是编写代码、设计界面还是实施功能,都可能出现各种各样的错误。这些错误可能导致软件无法正常运行、功能异常或者性能低下。为了及时发现和修复这些错误,需要进行系统而全面的错误寻找工作。 寻找错误的方法和技巧有很多种。其一种常用的方法是黑盒测试。黑盒测试是指在不了解软件内部结构和具体实现的情况下,通过输入一些指定的测试用例,观察软件的输出结果,并与预期结果进行对比,从而判断软件是否存在错误。另外一种方法是白盒测试。白盒测试是指在了解软件内部结构和具体实现的情况下,通过对代码进行逐行逐句的检查,发现其潜在的错误。 除了以上的方法,还可以使用自动化的测试工具来辅助寻找错误。这些工具能够模拟用户的操作,快速地执行大量的测试用例,并生成详细的测试报告,帮助开发人员准确定位和修复错误。 在寻找错误的过程,要保持耐心和专注。有时候错误可能隐藏得很深,需要仔细地析和调试。同时,还要注重记录和总结错误,以便后续的修复工作。 总之,寻找错误是软件开发过程不可或缺的一环。通过系统而全面的测试和调试工作,可以及时发现和修复软件存在的错误和缺陷,提高软件的质量和可靠性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值