POJ 2486 Apple Tree(树形dp) 题解

7 篇文章 0 订阅
6 篇文章 0 订阅

题目来源:

http://poj.org/problem?id=2486

题目描述:

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input 
Each test case contains three parts. 
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200) 
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i. 
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent. 
Input will be ended by the end of file. 

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1 
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2

解题思路:

     这题是比较难的树形dp,一开始只想到dp【i】【j】,表示从i出发经过j步的最大值,后来看到题解才知道要判断是否返回,所以要用dp【i】【j】【0/1】表示从i出发返回/不返回i经过j步取得的最大值,转移方程比较难想,需要结合图手绘一下,会更加深刻的理解,

dp【root】【j】【0】=max(dp【root】【j-k】【1】+dp【son】【k-1】【0】)

该方程表示在root出发走root的除son之外的子树走了j-k步并且回到root,然后从root出发到son要一步(所以k-1),再从son出发走k-1步不返回son。

dp【root】【j】【0】=max(dp【root】【j-k】【0】+dp【son】【k-2】【1】)

该方程表示从root出发到son要一步,再从son出发走k-2步返回son,son出发到root又要一步,(所以k-2),再从root出发走root的除son之外的子树走了j-k步并且不回到root

dp【root】【j】【1】=max(dp【root】【j-k】【1】+dp【son】【k-2】【1】)

该方程表示从root出发到son要一步,再从son出发走k-2步返回son,son出发到root又要一步,(所以k-2),再从root出发走root的除son之外的子树走了j-k步并且回到root

还有就是记得初始化和赋dp初值。。。

代码:

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
const int  maxn=1e5+10;
int dp[210][410][2],n,m,sum[210];
vector<int>E[110];
void dfs(int u,int fa)
{
	for(int i=0;i<=m;i++)dp[u][i][0]=dp[u][i][1]=sum[u];
	for(int i=0;i<E[u].size();i++)
	{
		int v=E[u][i];
		if(v==fa)continue;
		dfs(v,u);
		for(int j=m;j>=1;j--)
		for(int k=1;k<=j;k++)
		{
			if(k-1>=0)dp[u][j][0]=max(dp[u][j][0],dp[u][j-k][1]+dp[v][k-1][0]);
			if(k-2>=0)dp[u][j][0]=max(dp[u][j][0],dp[u][j-k][0]+dp[v][k-2][1]);
			if(k-2>=0)dp[u][j][1]=max(dp[u][j][1],dp[u][j-k][1]+dp[v][k-2][1]);
		}
	}
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)scanf("%d",&sum[i]),E[i].clear();
		for(int i=1;i<n;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			E[a].push_back(b);
			E[b].push_back(a);
		}
		dfs(1,0);
		printf("%d\n",max(dp[1][m][0],dp[1][m][1]));
	}
	return 0;	
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值