递推例题《农夫约翰与他的牛》

Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

  1. 1+1+1+1+1+1+1
  2. 1+1+1+1+1+2
  3. 1+1+1+2+2
  4. 1+1+1+4
  5. 1+2+2+2
  6. 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input
A single line with a single integer, N.

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input
7

Sample Output
6

译:

问题描述

农夫约翰命令他的牛寻找不同的数字集合,这些数字和一个给定的数字。奶牛只使用整数幂为2的数字。下面是可能的数字集合,它们的和是7:

1)1 + 1 + 1 + 1 + 1 + 1 + 1

2)1 + 1 + 1 + 1 + 1 + 2

3)1 + 1 + 1 + 2 + 2

4)1 + 1 + 1 + 4

5)1 + 2 + 2 + 2

6)1 + 2 + 4

帮助FJ计算一个给定整数N的所有可能表示形式(1 <= N <= 1,000,000)。

输入

一行只有一个整数N。

输出

表示N的方法的个数作为表示的和。由于这个数字可能很大,所以只打印最后9位数字(以10为基数表示)。

样例输入

7

样例输出

6

#include<stdio.h>
int result[1000000];
int n;
int count = 0;
void search(int k,int sum) {            // k为数组位置,从1开始; sum为当前前k个数字和。 
	for (int i = 1; i < n; i *= 2) {    // i为2的若干次幂 
		if (i >= result[k - 1]) {		// 保证比前一个数大
			result[k] = i;
			if (sum + i >= n) {
				if (sum + i == n)
					count++;
			}
			else
				search(k + 1, sum + i); // 嵌套递推函数(只要未超限即会一直当前已存数组下的所有可能性) 
		}
	}
}
int main() {
	scanf("%d", &n);
	search(1, 0);
	printf("%d", count);
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值