YTU OJ-1018: Give me the answer

1018: Give me the answer

Time Limit: 1 Sec   Memory Limit: 32 MB
Submit: 43   Solved: 10
[ Submit][ Status][ Web Board]

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number.
The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that
sum to 7:
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4
Help FJ count all possible representations for a given integer N (1 <= N <= 1 ,000,000)

Input

The first line of the input contains the number of test cases in the file. And t he first line of each case
contains one integer numbers n

Output

For each test case, output a line with the ans % 1000000000.

Sample Input

1
7

Sample Output

6

题解:这个题当数据量不大的时候,完全可以用搜索得出结果,但数据量大时,会超时。所以,可以先用dfs搜索得出前面若干项的结果,看一下有什么规律。

这个题从1开始,结果一次为 1   2   2   4   4   6   6   10   10   14   14   20   20   26   26   36   36   46   46   60   60   74。

递推公式:p[ i ]=(p[ i-1 ]+p[ i/2 ]) % mod ; (mod=1e9)


import java.util.*;

public class Give_me_the_answer {
static long [] a=new long[1020000];
static int n;
public static void f() {
a[1]=1;a[2]=2;
for(int i=2;i<1000010;i+=2) {
a[i]=(a[i-1]+a[i/2])%1000000000;
a[i+1]=a[i];
}
}
public static void main(String[] args) {
Scanner in=new Scanner(System.in);
int t;
t=in.nextInt();
while(t!=0) {
f();
n=in.nextInt();
System.out.println(a[n]);
t--;
}
}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值