HDU 2037 今年暑假不AC

原题目链接HDU2537


分类

HDU 贪心


题意

(经典贪心题目)
给出电视节目的开始与结束时间,求能完整看完的节目个数最多

样例输入输出

Sample Input

12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0

Sample Output

5

想法

先按结束时间从小到大排序,结束时间相同的按开始时间从小到大排序,贪心


代码

15ms

#include<bits/stdc++.h>
using namespace std;
struct tv
{
    int s;
    int e;
}a[105];
bool cmp(const tv a,const tv b){
    if(a.e!=b.e){
    	return a.e<b.e;
	}
	else{
		return a.s<b.s;
	}
}
int n;
int main(){
    while (cin>>n&&n)
    {
        for (int i = 0; i < n; i++){
            cin >> a[i].s >> a[i].e;
        }
        sort(a,a+n, cmp);
        int num = 0, l = 0;
        for (int i = 0; i < n; i++){
            if (l <= a[i].s){
                num++;
                l = a[i].e;
            }
        }
        cout << num << endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值