Easy Problem

描述

As we know, gcd(A, B) means the Greatest Common Divisor (GCD) of A and B.

But zy thinks it is so easy to just let you calculate it.
So now your task is to calculate gcd(A, B^B),it is easy right?

Notice: B ^ B means B multiply by himself B times.

输入

Multiply test case, each case per line.
Each line 2 integers A, B, 1 <= A, B <= 1000

输出

For each test case output one line( one number ), indicating the value of gcd (A, B^B)

样例输入1

100 1
100 2

样例输出1

1
4

C++实现:

#include<iostream>
#include<cmath>
using namespace std;

bool If_prime(int n)
{
    for(int i=2;i<=sqrt(n);i++)
        if(n%i==0)  return false;
    return true;
}

void prime_factor(int *a,int n)
{
    int i;
    for(i=2;i<=n;i++)
    {
        if(If_prime(i) && n%i==0)
        {
            a[i]++;
            n/=i;
            i--;
        }
    }
}

int main(){
    int a[500],b[500];
    int n,m,i,sum;

    while(cin>>n>>m){
        sum=1;
        for(i=0;i<500;i++)
        {
            a[i]=0;
            b[i]=0;
        }
        prime_factor(a,n);
        prime_factor(b,m);
        for(i=0;i<500;i++)
        {
            if(b[i])
            b[i]*=m;
        }
        for(i=0;i<500;i++)
        {
            if(a[i] && b[i])
            {
                sum*=pow(i,a[i]<b[i]?a[i]:b[i]);
            }
        }
        cout<<sum<<endl;
    }

    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Jaggar_F

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值