Easy Problem VI

SCU-4486
Time Limit: 1000 MS Memory Limit: 131072 K

Description

In this problem you are to calculate the sum of all integers from 1 to n, but you should take all powers of two with minus in the sum.

For example, for n=4 the sum is equal to -1-2+3-4=-4, because 1, 2 and 4 are 2^0, 2^1 and 2^2 respectively.

Calculate the answer for t values of n.

Input

The first line of the input contains a single integer t (1≤t≤100) — the number of values of n to be processed.

Each of next t lines contains a single integer n (1≤n≤10^9).

Output

Print the requested sum for each of t integers n given in the input.

Sample Input

2
4
1000000000

Sample Output

-4
499999998352516354
注释:注意不超时就行了

#include<stdio.h>
#include<string.h>
long long v[1000];
void  ff()
{
    v[1]=1;   
    for(int i=2; v[i]<=1000000000; i++)
    {//1<=2^n<=1000000000
        v[i]=v[i-1]*2;
    }
}
int main()
{
    int T;
    ff();
    scanf("%d",&T);
    while(T--)
    {
        long long n;
        int k;
        long long sum=0,ans=0;
        scanf("%lld",&n);
        sum=n*(n+1)/2;//等差公式不容易超时
        for(int i=1;v[i]<=n;i++)
            ans+=2*v[i];
        printf("%lld\n",sum-ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值