So much oil!!!

描述

The ZhouNiMa imperial family company is responsible for detecting underground oil deposits. ZhouNiMa works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

输入

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise and . Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

输出

For each grid,. Tw output the number of distinct oil depositso different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets,means that if it contains more than 100 pockets , you should …

样例输入1

1 1
*
3 5
@@*
@
@@*
1 8
@@***@
0 0

样例输出1

0
1
2

C++实现:

#include<iostream>
using namespace std;

void oil(char a[][101],int i,int j)
{
    a[i][j]='#';
    if(a[i][j-1]=='@' )
        oil(a,i,j-1);
    if(a[i][j+1]=='@' )
        oil(a,i,j+1);
    if(a[i-1][j-1]=='@' )
        oil(a,i-1,j-1);
    if(a[i-1][j+1]=='@' )
        oil(a,i-1,j+1);
    if(a[i-1][j]=='@' )
        oil(a,i-1,j);
    if(a[i+1][j-1]=='@' )
        oil(a,i+1,j-1);
    if(a[i+1][j+1]=='@' )
        oil(a,i+1,j+1);
    if(a[i+1][j]=='@' )
        oil(a,i+1,j);
}

int main(){
    char a[101][101];
    int x,y;
    while(cin>>x>>y)
    {
        if(x==0||y==0)
            return 0;
        int sum=0;
        for(int i=1;i<=x;i++)
        {
            for(int j=1;j<=y;j++)
            {
                cin>>a[i][j];
            }
        }
        for(int i=1;i<=x;i++)
        {
            for(int j=1;j<=y;j++)
            {
                if(a[i][j]=='@')
                {
                    oil(a,i,j);
                    sum++;
                }

            }
        }

        cout<<sum<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Jaggar_F

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值