PAT 1105 Spiral Matrix (25分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

题意:给定N个数,要我们把其拆分成一个二维数组,要求行>=列,且行-列是最小的。并且输出二维数组。

思路:首先是求行列,遍历一遍即可得到m-n最小;然后就是填充二维数组,我们用四个变量来标记它的四个角,r1=1,c1=1,r2=m,c2=n,然后顺时针遍历,这里需要注意,因为我习惯先给数组开空间,结果一直有个样例报段错误,后面意识到问题。然后全部放到main里面根据实际数据来开数组。

#include<bits/stdc++.h>
using namespace std;




bool cmp(int a,int b)
{
	return a > b;
}

int main()
{
	int N,n = 0,m = 99999997;
	int minn = 99999999;
	scanf("%d",&N);
	int a[N+2]; 
	for(int i = 1;i <= N;++i) scanf("%d",&a[i]);
	for(int i = 1;i*i <= N;++i)
	{
		if(N % i == 0)
		{
			int res = abs(N/i-i);
			if(res < minn)
			{
				m = max(N/i,i);
				n = min(N/i,i);
				minn = m -n;
			}
		}
	}
	int tmp[m+2][n+2]; 
	//从大到小排序 
	sort(a+1,a+1+N,cmp);
	//for(int i = 1;i <= N;++i) cout << a[i] << " "; 
	//顺时针排序,定义一个二维数组的四个角,慢慢填充
	int r1 = 1,c1 = 1,r2 = m,c2 = n;
	int idx = 1; //线性数组起始地址 
	while(r1 <= r2 && c1 <= c2)
	{
                
		for(int i = c1;i <= c2;++i)  tmp[r1][i] = a[idx++];
		for(int i = r1+1;i <= r2;++i) tmp[i][c2] = a[idx++];
		//这里如果防止出现列向量,比如N=7,实际就是7X1的二维向量。如果没有这一步判断会有问题 
		if(r1 < r2 && c1 < c2)
		{
			for(int i = c2-1;i > c1;--i) tmp[r2][i] = a[idx++];
			for(int i = r2;i > r1;--i) tmp[i][c1] = a[idx++];
		}
	
		r1++;
		c1++;
		r2--;
		c2--;
	}	
	
	for(int i = 1;i <= m;++i)
	{
		for(int j = 1;j <= n;++j)
		{
			if(j == 1) printf("%d",tmp[i][j]);
			else printf(" %d",tmp[i][j]);
		}
		printf("\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值