PAT 1045 Favorite Color Stripe (30分)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

 

题目大意:给出m中颜色作为喜欢的颜色(同时也给出顺序),然后给出一串长度为L的颜色序列,现在要去掉这个序列中的不喜欢的颜色,然后求剩下序列的一个子序列,使得这个子序列表示的颜色顺序符合自己喜欢的颜色的顺序,不一定要所有喜欢的颜色都出现(其实我没看懂英文,后面瞧了下其他人翻译的)

分析:因为喜欢的颜色是不重复的,把喜欢的颜色的序列按照存储到数组中,book[i] = j表示i颜色的下标为j。先在输入的时候剔除不在喜欢的序列中的元素,然后把剩余的保存在数组a中。 比如在{2 2 4 1 5 5 6 3 1 1 5 6}里面找符合 {2 3 1 5 6}这个顺序的子序列, 可以找到 {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}。子序列不一定要出现全部喜欢的颜色,只要符合给定喜欢序列的顺序即可,即我们的子序列要满足3在2后面,又在1前面。假设我们把给定的L长度序列中所有在喜欢序列中出现的全取出来,也就是一个新的序列,是不是就是一个最长子序列问题的?只不过我们需要判断的是组成的子序列是否满足顺序。比如我把这些去重后的元素保存在a[]中,a[i]表示第i个位置的元素,a[i]的值表示在喜欢序列中的位置。

#include<bits/stdc++.h>
using namespace std;

int vis[205],a[10005],dp[10005];

int main()
{
	int n,m,x;
	cin >> n >> m;
	for(int i = 1;i <= m;++i)
	{
		cin >> x;
		vis[x] = i;
	}	
	int l,cnt = 0,maxx = 0;
	cin >> l;
	for(int i = 1;i <= l;++i)
	{
		cin >> x;
		if(vis[x] >= 1)
			a[cnt++] = vis[x];
	}
	
	//最长子序列的问题,dp[i]表示前i个元素中符合顺序的最大长度 
	for(int i = 0;i < cnt;++i)
	{
		dp[i] = 1;
		for(int j = 0;j < i;++j)
		{
			if(a[i] >= a[j])
				dp[i] = max(dp[i],dp[j]+1);
			
		}
		maxx = max(dp[i],maxx);
	}
	cout << maxx << endl;
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值