CCCC - 天梯赛-关于堆的判断

点击打开链接

堆的简单模板: 点击打开链接
7-12   (25  分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N 1000)和M 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

题解:

        这道题目,不难是一道基础的数据结构题目,专门卡我们这些没有学过数据结构的新生,我在理解了堆的基本原理后,成功干掉了他。
#include <bits/stdc++.h>
using namespace std;


int ser[100007];
int CC = 10000;
const int MAX_N = (int)10000;
int heap[MAX_N],sz = 0;

void push(int x){
    // 自己结点的编号
    int i = sz ++;

    while (i > 0){
        // 父亲结点的编号
        int p = (i-1)/2;

        // 如果已经没有大小颠倒则退出
        if (heap[p] <= x) break;

        // 把父亲结点的数值放下来,而把自己提上去
        heap[i] = heap[p];
        i = p;
    }

    heap[i] = x;
}

int pop() {
    // 最小值
    int ret = heap[0];

    // 要提到根的数值
    int x = heap[--sz];

    // 从根开始向下交换
    int i = 0;
    while (i*2 + 1 < sz){
        // 比较儿子的值
        int lson = i*2 + 1,rson = i*2 + 2;
        if (rson < sz && heap[rson] < heap[lson]) lson = rson;

        // 如果已经没有大小颠倒则退出
        if (heap[lson] >= x)break;

        // 把儿子的数值提上来
        heap[i] = heap[lson];

        i = lson;
    }

    heap[i] = x;

    return ret;
}

char str[10][100];

int pre(int x){
    return (ser[x+CC]-1)/2;
}

int main()
{
    ios::sync_with_stdio(false);

    int n,q;
    cin >> n >> q;

    int t;
    for (int i = 1;i <= n;i ++) {
        cin >> t;
        push(t);
    }

    for (int i = 0;i < n;i ++){
        ser[heap[i]+CC] = i;
        //cout << "ser " << i << ',' << heap[i] << endl;
    }

    while (q --){
        int a,b;
        cin >> a;

        cin >> str[1];
        if (str[1][0] == 'a'){
            cin >> b;
            cin >> str[2] >> str[3];
            // 判断兄弟结点
            if ((ser[a+CC]-1)/2 == (ser[b+CC]-1)/2)cout << "T";
            else cout << "F";

        }else {
            cin >> str[2];
            if (str[2][0] == 'a'){
                cin >> str[3] >> str[4] >> b;
                // 判断孩子结点
                if (ser[b+CC] == pre(a))cout << "T";
                else cout << "F";
            }else {
                cin >> str[3];
                if (str[3][0] == 'r'){
                    // 判断根结点

                    if (ser[a+CC] == 0)cout << "T";
                    else  cout << "F";

                }else {
                    cin >> str[4] >> b;
                    //判断 父母结点
                    if (pre(b) == ser[a+CC]) cout << "T";
                    else cout << "F";
                }
            }
        }
        cout << endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值